Bug 908488 - [or] pofilter newlines test failed
[or] pofilter newlines test failed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: i18n, Translation
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-02-06 15:26 EST by John Sefler
Modified: 2014-06-17 20:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:58:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-02-06 15:26:26 EST
Description of problem:

# (pofilter) newlines: Different line endings
msgid ""
"\n"
"Unable to register.\n"
"For further assistance, please contact Red Hat Global Support Services."
msgstr ""
"\n"
"ପଞ୍ଜିକରଣ କରିବାରେ ଅସମର୍ଥ। ଅଧିକ ସହାୟତା ପାଇଁ, ଦୟାକରି Red Hat ଜାଗତିକ ସହାୟତା ସର୍ଭିସ ସହିତ ସମ୍ପର୍କ କରନ୍ତୁ।"

Please include another "\n" newline substring at the right place in the msgstr above.


# (pofilter) newlines: Different line endings
msgid "Unable to perform refresh due to the following exception: %s"
msgstr ""
"ନିମ୍ନଲିଖିତ ବ୍ୟତୀକ୍ରମ ହେତୁ ସତେଜ କରିବାରେ ଅସମର୍ଥ \n"
" ତ୍ରୁଟି: %s"

Please remove the "\n" newline substring from the msgstr above.



Version-Release number of selected component (if applicable):
[root@jsefler-7 ~]# rpm -q subscription-manager
subscription-manager-1.8.1-1.git.9.f23e0b0.el7.x86_64
https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.8.X
Comment 1 John Sefler 2013-02-06 15:33:36 EST
Also, please fix this translation...

[root@jsefler-7 ~]# msgunfmt --no-wrap /usr/share/locale/or/LC_MESSAGES/rhsm.mo | grep -B1 -A7 "Redeeming the subscription"
msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr ""
"ସଦସ୍ୟତାକୁ ହ୍ରାସ କରିବା ପାଇଁ କିଛି ସମୟ ନେଇପାରେ।\n"
"ବିଜ୍ଞପ୍ତି ପାଇବା ପାଇଁ ଦୟାକରି ଗୋଟିଏ ଇମେଲ ଠିକଣା ପ୍ରଦାନ କରନ୍ତୁ ଯେତେବେଳେ ତାହା ସମାପ୍ତ ହୋଇଥାଏ।\n"
"when the redemption is complete."

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
That looks more like English than Oriya
Comment 2 Manoj Kumar Giri 2013-02-07 02:27:58 EST
Corrected translation errors and updated in subscription-manager-1.8.X

Thanks,
Manoj
Comment 3 Adrian Likins 2013-03-25 17:35:24 EDT
commit 008c5cb336b141f300d647d6c71750b2cd15e066
Author: Adrian Likins <alikins@redhat.com>
Date:   Mon Mar 25 15:03:16 2013 -0400

    921126: latest string updates from zanata
    
    921126,911779,911776,911772,911764,911762,911759,
    911757,908886,908879,908869,908866,908521,908511,
    908488,908434,908108,908059,908037,906967,906552,
    842784
Comment 4 John Sefler 2013-04-11 17:53:27 EDT
Verifying Version...
[root@jsefler-5 ~]# rpm -q subscription-manager
subscription-manager-1.8.5-1.el5


[root@jsefler-5 ~]# msgunfmt /usr/share/locale/or/LC_MESSAGES/rhsm.mo | grep "For further assistance" -B3 -A5
msgid ""
"\n"
"Unable to register.\n"
"For further assistance, please contact Red Hat Global Support Services."
msgstr ""
"\n"
"ପଞ୍ଜିକରଣ କରିବାରେ ଅସମର୍ଥ। \n"
"ଅଧିକ ସହାୟତା ପାଇଁ, ଦୟାକରି Red Hat ଜାଗତିକ ସହାୟତା ସର୍ଭିସ ସହିତ ସମ୍ପର୍କ କରନ୍ତୁ।"

[root@jsefler-5 ~]# msgunfmt /usr/share/locale/or/LC_MESSAGES/rhsm.mo | grep "Unable to perform refresh" -A2
msgid "Unable to perform refresh due to the following exception: %s"
msgstr "ନିମ୍ନଲିଖିତ ବ୍ୟତୀକ୍ରମ ହେତୁ ସତେଜ କରିବାରେ ଅସମର୍ଥି: %s"

[root@jsefler-5 ~]# msgunfmt --no-wrap /usr/share/locale/or/LC_MESSAGES/rhsm.mo | grep -B1 -A6 "Redeeming the subscription"
msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr ""
"ସଦସ୍ୟତାକୁ ହ୍ରାସ କରିବା ପାଇଁ କିଛି ସମୟ ନେଇପାରେ।\n"
"ବିଜ୍ଞପ୍ତି ପାଇବା ପାଇଁ ଦୟାକରି ଗୋଟିଏ ଇମେଲ ଠିକଣା ପ୍ରଦାନ କରନ୍ତୁ ଯେତେବେଳେ ତାହା ସମାପ୍ତ ହୋଇଥାଏ।"

[root@jsefler-5 ~]# 


VERIFIED: all three issues are fixed.
Comment 5 Ludek Smid 2014-06-13 07:58:32 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.