Bug 90849 - PPPoE ADSL connection drops if idle
Summary: PPPoE ADSL connection drops if idle
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-14 17:10 UTC by Need Real Name
Modified: 2015-01-08 00:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 09:31:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-05-14 17:10:35 UTC
Description of problem:
After upgrading from Red Hat 7.2 to 9.0, running "adsl-start" brings up the
adsl pppoe connection correctly, but it drops if left idle for a short time
(like 1 minute or so).  This did not happen under 7.2.  Running a continuous
"ping" in the background (with 10 second ping interval) stops the connection
from dropping, so I've been doing that to stay online.

Version-Release number of selected component (if applicable):


How reproducible:
See above.

Steps to Reproduce:
1. run adsl-start to connect to pppoe adsl provider
2. wait 3 minutes
3.
    
Actual results:
connection fails

Expected results:
connection should stay up

Additional info:

Comment 1 Josiah Royse 2003-05-14 19:18:11 UTC
Yes this is annoying- here is a temporary fix:

in /etc/sysconfig/network-scripts/ifcfg-ppp0 comment out the timeout like this:

#PPPOE_TIMEOUT=20


Comment 2 Thomas Woerner 2004-08-17 09:31:45 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Note You need to log in before you can comment on or make changes to this bug.