Bug 908497 - Latest 1.7.0 openjdk breaks JBoss AS 7.1.1.Final
Latest 1.7.0 openjdk breaks JBoss AS 7.1.1.Final
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
: 908617 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-06 15:56 EST by Harold Campbell
Modified: 2013-02-07 21:01 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 21:01:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harold Campbell 2013-02-06 15:56:45 EST
Description of problem:

With the latest jdk, java-1.7.0-openjdk.x86_64 1:1.7.0.9-2.3.5.fc18, JBoss AS 7.1.1.Final will not start. Downgrading jdk to 1:1.7.0.9-2.3.3.fc18.1 gets things working again.


Version-Release number of selected component (if applicable):
java-1.7.0-openjdk.x86_64 1:1.7.0.9-2.3.5.fc18

How reproducible:
Every time

Steps to Reproduce:
1. Install jdk update
2. Try to start AS
3. profit
  
Actual results:
$ bin/standalone.sh -b 0.0.0.0
=========================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: /home/hcamp/tools/jboss-as

  JAVA: /usr/lib/jvm/java/bin/java

  JAVA_OPTS:  -server -XX:+UseCompressedOops -XX:+TieredCompilation -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Djboss.server.default.config=standalone.xml

=========================================================================

Exception in thread "main" java.lang.ExceptionInInitializerError
	at org.jboss.as.server.Main.main(Main.java:73)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.jboss.modules.Module.run(Module.java:260)
	at org.jboss.modules.Main.main(Main.java:291)
Caused by: java.lang.IllegalStateException: The LogManager was not properly installed (you must set the "java.util.logging.manager" system property to "org.jboss.logmanager.LogManager")
	at org.jboss.logmanager.Logger.getLogger(Logger.java:60)
	at org.jboss.logmanager.log4j.BridgeRepositorySelector.<clinit>(BridgeRepositorySelector.java:42)
	... 7 more


Expected results:
Startup without stacktraces.

Additional info:
Comment 1 Fedora Update System 2013-02-06 21:07:39 EST
java-1.7.0-openjdk-1.7.0.9-2.3.5.fc18.1 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/java-1.7.0-openjdk-1.7.0.9-2.3.5.fc18.1
Comment 2 shu ming 2013-02-07 04:05:46 EST
*** Bug 908617 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2013-02-07 21:01:42 EST
java-1.7.0-openjdk-1.7.0.9-2.3.5.fc18.1 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.