Bug 908547 - Please remove bogus compressed texture size checks which crash Torchlight
Summary: Please remove bogus compressed texture size checks which crash Torchlight
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mesa
Version: 6.4
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Dave Airlie
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-07 01:11 UTC by Gris Ge
Modified: 2014-01-02 09:09 UTC (History)
2 users (show)

Fixed In Version: mesa-9.2-0.1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 06:22:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1559 normal SHIPPED_LIVE mesa bug fix and enhancement update 2013-11-20 21:40:20 UTC

Description Gris Ge 2013-02-07 01:11:53 UTC
Description of problem:
Please check upstream bug for detail: 
https://bugs.freedesktop.org/show_bug.cgi?id=55445

The patch is:
http://cgit.freedesktop.org/mesa/mesa/commit?id=df4a88ac4398ec4c152eb57a7129c07bb623edd7

Version-Release number of selected component (if applicable):
mesa-libGLU-devel-9.0-0.7.el6.x86_64
mesa-libGL-9.0-0.7.el6.x86_64
mesa-dri1-drivers-7.11-8.el6.x86_64
mesa-libGLU-9.0-0.7.el6.x86_64
mesa-dri-filesystem-9.0-0.7.el6.x86_64
mesa-libGL-devel-9.0-0.7.el6.x86_64
mesa-dri-drivers-9.0-0.7.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Enter Torchlight floor 20
2.
3.
  
Actual results:
Crash

Expected results:
Not crash

Additional info:
Patch tested.

Comment 6 Tomas Pelka 2013-09-19 13:44:38 UTC
Gris, 

could you please recheck with new mesa?

Thanks
tom

Comment 7 Gris Ge 2013-09-21 13:49:15 UTC
Sure.

It will take a while before I enter floor 20.

Comment 8 Gris Ge 2013-10-08 12:22:37 UTC
I entered floor 21 with no problem found for RHEL6.5-20130925.2:

=====
mesa-dri1-drivers-7.11-8.el6.x86_64
mesa-dri-filesystem-9.2-0.5.el6.x86_64
mesa-libGLU-9.2-0.5.el6.x86_64
mesa-libEGL-9.2-0.5.el6.x86_64
mesa-private-llvm-3.3-0.3.rc3.el6.x86_64
mesa-dri-drivers-9.2-0.5.el6.x86_64
mesa-dri-drivers-9.2-0.5.el6.i686
mesa-libGL-devel-9.2-0.5.el6.x86_64
mesa-libGL-9.2-0.5.el6.i686
mesa-libGL-9.2-0.5.el6.x86_64
mesa-dri-filesystem-9.2-0.5.el6.i686
mesa-libGLU-devel-9.2-0.5.el6.x86_64
mesa-private-llvm-devel-3.3-0.3.rc3.el6.x86_64
mesa-libgbm-9.2-0.5.el6.x86_64
mesa-libGLU-9.2-0.5.el6.i686
mesa-private-llvm-3.3-0.3.rc3.el6.i686
======

Comment 9 errata-xmlrpc 2013-11-21 06:22:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1559.html


Note You need to log in before you can comment on or make changes to this bug.