Bug 908592 - Anaconda may generate invalid anaconda-ks.cfg
Anaconda may generate invalid anaconda-ks.cfg
Status: CLOSED DUPLICATE of bug 888841
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-07 00:08 EST by smitna
Modified: 2013-02-07 09:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 09:41:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda logs and generated (invalid) kickstart file following successful install (53.98 KB, application/x-xz)
2013-02-07 00:08 EST, smitna
no flags Details

  None (edit)
Description smitna 2013-02-07 00:08:57 EST
Created attachment 694248 [details]
anaconda logs and generated (invalid) kickstart file following successful install

When anaconda version 18.37.11 prompted to restart following a successful install, I switched to vt2 and sent signal USR2 to all anaconda instances but no non-empty files were generated matching the shell pattern /tmp/anaconda-tb-*

I have attached these files instead:

/tmp/X.log
/tmp/anaconda.log
/tmp/ifcfg.log
/tmp/packaging.log
/tmp/program.log
/tmp/storage.log
/tmp/syslog
/mnt/sysimage/root/anaconda-ks.cfg

The kickstart file created by anaconda from this successful install (anaconda-ks.cfg) causes this exception when passed via the inst.ks boot parameter:

pykickstart.errors.KickstartParseError: The following problem occurred on line 22 of the kickstart file:

Unknown command: --type=lvm
Comment 1 Chris Lumens 2013-02-07 09:41:22 EST

*** This bug has been marked as a duplicate of bug 888841 ***

Note You need to log in before you can comment on or make changes to this bug.