Bug 908725 - virtio win inf does not specify revision ID
Summary: virtio win inf does not specify revision ID
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-07 11:46 UTC by Michael S. Tsirkin
Modified: 2013-11-22 00:03 UTC (History)
8 users (show)

(edit)
Cause: inf files come without explicit specification of revision ID.

Consequence: perfectly fine from Windows point of view but violates some virtio spec requirements.

Fix: add revision id to inf files.

Result: inf files explicitly specify revision id as part of HW identification string.
Clone Of:
(edit)
Last Closed: 2013-11-22 00:03:29 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1729 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-11-21 00:39:25 UTC

Description Michael S. Tsirkin 2013-02-07 11:46:59 UTC
Description of problem:
virtio spec says that drivers should not bind to devices unless
revision ID is 0x0.

virtio-win drivers violate this spec, which will create
backwards compatibility problems down the road.

Version-Release number of selected component (if applicable):
WHQL version from 6.4

How reproducible:
always

Steps to Reproduce:
1. open qemu source, edit hw/virtio-pci.c, change
      revision from VIRTIO_PCI_ABI_VERSION to 0x1.
2. start windows guest with any virtio devices besides baloon,
   and with virtio drivers loaded

  
Actual results:
guest driver loads

Expected results:
driver should not load, should prompt with no driver found dialog

Additional info:

Comment 4 Mike Cao 2013-03-29 06:55:49 UTC
Pls show me how to verify it ,Will something be added in XXX.inf ?

Comment 5 Vadim Rozenfeld 2013-03-29 07:33:36 UTC
(In reply to comment #4)
> Pls show me how to verify it ,Will something be added in XXX.inf ?

yes, it's in INFs

For example for virtio-scsi inf specifies the full
HW id string as:
%RHELScsi.DeviceDesc% = rhelscsi_inst, PCI\VEN_1AF4&DEV_1004&SUBSYS_00081AF4&REV_00

where the last 7 symbols ('REV_00') is the revision ID.

Comment 13 errata-xmlrpc 2013-11-22 00:03:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html


Note You need to log in before you can comment on or make changes to this bug.