Bug 908759 - [abrt] sssd-1.9.3-1.fc18: talloc_abort: Process /usr/libexec/sssd/sssd_be was killed by signal 6 (SIGABRT)
[abrt] sssd-1.9.3-1.fc18: talloc_abort: Process /usr/libexec/sssd/sssd_be was...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
abrt_hash:155aca0669c7033acd9ce5a1e1d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-07 07:52 EST by Stef Walter
Modified: 2013-05-15 13:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: sssd-1.10.0-3.fc19.beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 13:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (12.39 KB, text/plain)
2013-02-07 07:52 EST, Stef Walter
no flags Details
File: cgroup (154 bytes, text/plain)
2013-02-07 07:53 EST, Stef Walter
no flags Details
File: core_backtrace (1.60 KB, text/plain)
2013-02-07 07:53 EST, Stef Walter
no flags Details
File: dso_list (6.41 KB, text/plain)
2013-02-07 07:54 EST, Stef Walter
no flags Details
File: environ (196 bytes, text/plain)
2013-02-07 07:55 EST, Stef Walter
no flags Details
File: limits (1.29 KB, text/plain)
2013-02-07 07:55 EST, Stef Walter
no flags Details
File: maps (29.93 KB, text/plain)
2013-02-07 07:55 EST, Stef Walter
no flags Details
File: open_fds (1.06 KB, text/plain)
2013-02-07 07:55 EST, Stef Walter
no flags Details
File: proc_pid_status (885 bytes, text/plain)
2013-02-07 07:55 EST, Stef Walter
no flags Details
File: smolt_data (2.82 KB, text/plain)
2013-02-07 07:56 EST, Stef Walter
no flags Details

  None (edit)
Description Stef Walter 2013-02-07 07:52:45 EST
Description of problem:
Ran ipa-client-install to join an IPA domain. 10 minutes later sssd crash notification came up.

Version-Release number of selected component:
sssd-1.9.3-1.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/libexec/sssd/sssd_be --domain ipa.thewalter.lan --debug-to-files
crash_function: talloc_abort
executable:     /usr/libexec/sssd/sssd_be
kernel:         3.6.6-3.fc18.x86_64
remote_result:  NOTFOUND
uid:            0
var_log_messages: Feb  7 13:31:37 stef-rawhide-thewalter-lan abrt[9689]: Saved core dump of pid 8282 (/usr/libexec/sssd/sssd_be) to /var/spool/abrt/ccpp-2013-02-07-13:31:36-8282 (18923520 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 talloc_abort at ../talloc.c:317
 #3 talloc_abort_access_after_free at ../talloc.c:336
 #4 talloc_chunk_from_ptr at ../talloc.c:357
 #6 talloc_get_name at ../talloc.c:1153
 #7 talloc_check_name at ../talloc.c:1172
 #8 ipa_dyndns_child_handler at src/providers/ipa/ipa_dyndns.c:1173
 #9 child_invoke_callback at src/util/child_common.c:578
 #10 tevent_common_loop_immediate at ../tevent_immediate.c:135
 #11 std_event_loop_once at ../tevent_standard.c:556
 #12 _tevent_loop_once at ../tevent.c:507
Comment 1 Stef Walter 2013-02-07 07:52:50 EST
Created attachment 694448 [details]
File: backtrace
Comment 2 Stef Walter 2013-02-07 07:53:13 EST
Created attachment 694449 [details]
File: cgroup
Comment 3 Stef Walter 2013-02-07 07:53:53 EST
Created attachment 694450 [details]
File: core_backtrace
Comment 4 Stef Walter 2013-02-07 07:54:39 EST
Created attachment 694451 [details]
File: dso_list
Comment 5 Stef Walter 2013-02-07 07:55:17 EST
Created attachment 694452 [details]
File: environ
Comment 6 Stef Walter 2013-02-07 07:55:21 EST
Created attachment 694453 [details]
File: limits
Comment 7 Stef Walter 2013-02-07 07:55:23 EST
Created attachment 694454 [details]
File: maps
Comment 8 Stef Walter 2013-02-07 07:55:31 EST
Created attachment 694455 [details]
File: open_fds
Comment 9 Stef Walter 2013-02-07 07:55:53 EST
Created attachment 694456 [details]
File: proc_pid_status
Comment 10 Stef Walter 2013-02-07 07:56:05 EST
Created attachment 694457 [details]
File: smolt_data
Comment 11 Jakub Hrozek 2013-02-07 13:18:57 EST
Thank you for the bug report. Can you check if there is anything in /var/log/sssd/sssd_ipa.thewalter.lan.log ? The reason why the SSSD crashed was an access-after-free and we should be logging those by default.
Comment 12 Jakub Hrozek 2013-02-07 13:22:41 EST
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1802
Comment 13 Stef Walter 2013-02-11 14:55:10 EST
Hmmm, my sssd_ipa.thewalter.lan.log is empty, and has been since last year. Is there something i should have in /etc/sssd/sssd.conf by default?
Comment 14 Jakub Hrozek 2013-02-12 04:14:15 EST
(In reply to comment #13)
> Hmmm, my sssd_ipa.thewalter.lan.log is empty, and has been since last year.
> Is there something i should have in /etc/sssd/sssd.conf by default?

No, we added a support to include talloc logs in SSSD's debug logs at the most verbose level. You should see them even if debug_level is set to 0. If you don't, then probably talloc didn't detect the problem on its own.
Comment 15 Pavel Březina 2013-02-25 05:29:13 EST
Hi, the backtrace says that it was detected by talloc so there definitely should be a message. Is it possible that you have disabled debugging to files?
Comment 16 dwesterg 2013-03-11 10:26:29 EDT
sssd is configured to work with kerberos and nis.  ypbind may or may not be running depending on network connectivity

backtrace_rating: 4
Package: sssd-1.9.4-5.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 17 Jakub Hrozek 2013-03-17 18:01:08 EDT
(In reply to comment #16)
> sssd is configured to work with kerberos and nis.  ypbind may or may not be
> running depending on network connectivity
> 
> backtrace_rating: 4
> Package: sssd-1.9.4-5.fc18
> OS Release: Fedora release 18 (Spherical Cow)

I'm reasonably sure that this is a different issue as the code in question is only ever reachable when using the IPA provider. Can you open a new bug?
Comment 18 Fedora Update System 2013-05-05 10:44:52 EDT
sssd-1.10.0-3.fc19.beta1 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sssd-1.10.0-3.fc19.beta1
Comment 19 Fedora Update System 2013-05-05 13:10:15 EDT
Package sssd-1.10.0-3.fc19.beta1:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sssd-1.10.0-3.fc19.beta1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7450/sssd-1.10.0-3.fc19.beta1
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2013-05-07 10:37:11 EDT
sssd-1.10.0-4.fc19.beta1 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sssd-1.10.0-4.fc19.beta1
Comment 21 Fedora Update System 2013-05-15 13:29:29 EDT
sssd-1.10.0-3.fc19.beta1 has been pushed to the Fedora 19 obsolete repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.