Bug 908776 - vdsm: can't create iSCSI domain with "-" or "_" in the lun name
vdsm: can't create iSCSI domain with "-" or "_" in the lun name
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity urgent
: ---
: 3.2.0
Assigned To: Yeela Kaplan
Elad
storage
: Regression
: 703739 (view as bug list)
Depends On:
Blocks: 907252 915537
  Show dependency treegraph
 
Reported: 2013-02-07 08:50 EST by Dafna Ron
Modified: 2016-02-10 15:23 EST (History)
13 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-8.0.el6ev
Doc Type: Bug Fix
Doc Text:
The LVM filter implemented in VDSM now supports device names with udev special characters, including hyphens (-), underscores (_), and spaces ( ). Users can now create storage domains and LUNs with unicode characters in their names.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (364.16 KB, application/x-gzip)
2013-02-07 08:50 EST, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11852 None None None Never

  None (edit)
Description Dafna Ron 2013-02-07 08:50:48 EST
Created attachment 694489 [details]
logs

Description of problem:

when trying to create a new domain we are failing on pvcreate because of special charicheters added (1Dafna\\\\x2dsf5\\\\x2d011359900)
as a result, every lun is shown as if its used. 

Version-Release number of selected component (if applicable):

sf5
vdsm-4.10.2-7.0.el6ev.x86_64

How reproducible:

100%

Steps to Reproduce:
1. create a new lun on iscsi storage
2. connecto to the lun and try to create the domain
3.
  
Actual results:

we detect the lun as already used: 

This operation might be unrecoverable and destructive!
The following LUNs are already in use:
- 1Dafna-sf6-011360241

looking at vdsm logs, the pvcreate is failing because of \\\\x2dsf5\\\\x added to the lun

Expected results:

lun is not used and should not be shown as such 

Additional info: logs


Thread-1761::DEBUG::2013-02-07 15:00:37,859::misc::83::Storage.Misc.excCmd::(<lambda>) '/usr/bin/sudo -n /sbin/lvm pvcreate --config " devices { preferred_names = [\\"^/dev/mapper/\\"] ignore_suspended_devices=1 write_cache_state=0 disa
ble_after_error_count=3 filter = [ \'a%1Dafna\\\\x2dNew11360241|1Dafna\\\\x2dNew21360241|1Dafna\\\\x2dNew31360241|1Dafna\\\\x2dsf5\\\\x2d011359900|1Dafna\\\\x2dsf5\\\\x2d021359900|1Dafna\\\\x2dsf6\\\\x2d011360241|1Dafna\\\\x2dsf6\\\\x2d
021360241|1Dafna\\\\x2dsf6\\\\x2d031360241%\', \'r%.*%\' ] }  global {  locking_type=1  prioritise_write_locks=1  wait_for_locks=1 }  backup {  retain_min = 50  retain_days = 0 } " --test --metadatasize 128m --metadatacopies 2 --metadat
aignore y /dev/mapper/1Dafna-sf6-011360241 /dev/mapper/1Dafna-sf5-011359900 /dev/mapper/1Dafna-sf6-021360241 /dev/mapper/1Dafna-sf5-021359900 /dev/mapper/1Dafna-sf6-031360241 /dev/mapper/1Dafna-New11360241 /dev/mapper/1Dafna-New21360241
 /dev/mapper/1Dafna-New31360241' (cwd None)
Thread-1761::DEBUG::2013-02-07 15:00:38,093::misc::83::Storage.Misc.excCmd::(<lambda>) FAILED: <err> = '  TEST MODE: Metadata will NOT be updated and volumes will not be (de)activated.\n  Device /dev/mapper/1Dafna-sf6-011360241 not foun
d (or ignored by filtering).\n  Device /dev/mapper/1Dafna-sf5-011359900 not found (or ignored by filtering).\n  Device /dev/mapper/1Dafna-sf6-021360241 not found (or ignored by filtering).\n  Device /dev/mapper/1Dafna-sf5-021359900 not 
found (or ignored by filtering).\n  Device /dev/mapper/1Dafna-sf6-031360241 not found (or ignored by filtering).\n  Device /dev/mapper/1Dafna-New11360241 not found (or ignored by filtering).\n  Device /dev/mapper/1Dafna-New21360241 not 
found (or ignored by filtering).\n  Device /dev/mapper/1Dafna-New31360241 not found (or ignored by filtering).\n'; <rc> = 5
Thread-1761::DEBUG::2013-02-07 15:00:38,096::lvm::813::Storage.LVM::(testPVCreate) rc: 5, out: [], err: ['  TEST MODE: Metadata will NOT be updated and volumes will not be (de)activated.', '  Device /dev/mapper/1Dafna-sf6-011360241 not 
found (or ignored by filtering).', '  Device /dev/mapper/1Dafna-sf5-011359900 not found (or ignored by filtering).', '  Device /dev/mapper/1Dafna-sf6-021360241 not found (or ignored by filtering).', '  Device /dev/mapper/1Dafna-sf5-0213
59900 not found (or ignored by filtering).', '  Device /dev/mapper/1Dafna-sf6-031360241 not found (or ignored by filtering).', '  Device /dev/mapper/1Dafna-New11360241 not found (or ignored by filtering).', '  Device /dev/mapper/1Dafna-
New21360241 not found (or ignored by filtering).', '  Device /dev/mapper/1Dafna-New31360241 not found (or ignored by filtering).'], unusedDevs: set([]), usedDevs: set(['/dev/mapper/1Dafna-sf5-021359900', '/dev/mapper/1Dafna-sf5-01135990
0', '/dev/mapper/1Dafna-sf6-011360241', '/dev/mapper/1Dafna-sf6-031360241', '/dev/mapper/1Dafna-New21360241', '/dev/mapper/1Dafna-New11360241', '/dev/mapper/1Dafna-New31360241', '/dev/mapper/1Dafna-sf6-021360241'])
Thread-1761::INFO::2013-02-07 15:00:38,099::logUtils::39::dispatcher::(wrapper) Run and protect: getDeviceList, Return response: {'devList': [{'status': 'used', 'vendorID': 'IET', 'capacity': '107374182400', 'fwrev': '0001', 'vgUUID': '
', 'pathlist': [{'initiatorname': 'default', 'connection': '10.35.64.10', 'iqn': 'Dafna-sf6-01', 'portal': '1', 'password': '******', 'port': '3260'}], 'logicalblocksize': '512', 'pathstatus': [{'physdev': 'sdb', 'type': 'iSCSI', 'state
': 'active', 'lun': '1'}], 'devtype': 'iSCSI', 'physicalblocksize': '512', 'pvUUID': '', 'serial': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-sf6-011360241', 'productID': 'VIRTUAL-DISK'}, {'status': 'used', 'vendorID': '', 'capacity': '107374
182400', 'fwrev': '', 'vgUUID': '', 'pathlist': [], 'logicalblocksize': '', 'pathstatus': [], 'devtype': '', 'physicalblocksize': '', 'pvUUID': '', 'serial': '', 'GUID': '1Dafna-sf5-011359900', 'productID': ''}, {'status': 'used', 'vend
orID': 'IET', 'capacity': '107374182400', 'fwrev': '0001', 'vgUUID': '', 'pathlist': [{'initiatorname': 'default', 'connection': '10.35.64.10', 'iqn': 'Dafna-sf6-02', 'portal': '1', 'password': '******', 'port': '3260'}], 'logicalblocks
ize': '512', 'pathstatus': [{'physdev': 'sdc', 'type': 'iSCSI', 'state': 'active', 'lun': '1'}], 'devtype': 'iSCSI', 'physicalblocksize': '512', 'pvUUID': '', 'serial': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-sf6-021360241', 'productID': '
VIRTUAL-DISK'}, {'status': 'used', 'vendorID': '', 'capacity': '107374182400', 'fwrev': '', 'vgUUID': '', 'pathlist': [], 'logicalblocksize': '', 'pathstatus': [], 'devtype': '', 'physicalblocksize': '', 'pvUUID': '', 'serial': '', 'GUI
D': '1Dafna-sf5-021359900', 'productID': ''}, {'status': 'used', 'vendorID': 'IET', 'capacity': '107374182400', 'fwrev': '0001', 'vgUUID': '', 'pathlist': [{'initiatorname': 'default', 'connection': '10.35.64.10', 'iqn': 'Dafna-sf6-03',
 'portal': '1', 'password': '******', 'port': '3260'}], 'logicalblocksize': '512', 'pathstatus': [{'physdev': 'sdd', 'type': 'iSCSI', 'state': 'active', 'lun': '1'}], 'devtype': 'iSCSI', 'physicalblocksize': '512', 'pvUUID': '', 'serial
': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-sf6-031360241', 'productID': 'VIRTUAL-DISK'}, {'status': 'used', 'vendorID': 'IET', 'capacity': '53687091200', 'fwrev': '0001', 'vgUUID': '', 'pathlist': [{'initiatorname': 'default', 'connection'
: '10.35.64.10', 'iqn': 'Dafna-New1', 'portal': '1', 'password': '******', 'port': '3260'}], 'logicalblocksize': '512', 'pathstatus': [{'physdev': 'sde', 'type': 'iSCSI', 'state': 'active', 'lun': '1'}], 'devtype': 'iSCSI', 'physicalblo
cksize': '512', 'pvUUID': '', 'serial': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-New11360241', 'productID': 'VIRTUAL-DISK'}, {'status': 'used', 'vendorID': 'IET', 'capacity': '53687091200', 'fwrev': '0001', 'vgUUID': '', 'pathlist': [{'init
iatorname': 'default', 'connection': '10.35.64.10', 'iqn': 'Dafna-New2', 'portal': '1', 'password': '******', 'port': '3260'}], 'logicalblocksize': '512', 'pathstatus': [{'physdev': 'sdf', 'type': 'iSCSI', 'state': 'active', 'lun': '1'}
], 'devtype': 'iSCSI', 'physicalblocksize': '512', 'pvUUID': '', 'serial': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-New21360241', 'productID': 'VIRTUAL-DISK'}, {'status': 'used', 'vendorID': 'IET', 'capacity': '53687091200', 'fwrev': '0001'
, 'vgUUID': '', 'pathlist': [{'initiatorname': 'default', 'connection': '10.35.64.10', 'iqn': 'Dafna-New3', 'portal': '1', 'password': '******', 'port': '3260'}], 'logicalblocksize': '512', 'pathstatus': [{'physdev': 'sdg', 'type': 'iSC
SI', 'state': 'active', 'lun': '1'}], 'devtype': 'iSCSI', 'physicalblocksize': '512', 'pvUUID': '', 'serial': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-New31360241', 'productID': 'VIRTUAL-DISK'}]}
Thread-1761::DEBUG::2013-02-07 15:00:38,099::task::1151::TaskManager.Task::(prepare) Task=`a1681ab3-ebfd-48d4-95fb-997ccdd7e1ec`::finished: {'devList': [{'status': 'used', 'fwrev': '0001', 'vgUUID': '', 'pathlist': [{'connection': '10.3
5.64.10', 'iqn': 'Dafna-sf6-01', 'portal': '1', 'port': '3260', 'initiatorname': 'default'}], 'logicalblocksize': '512', 'devtype': 'iSCSI', 'physicalblocksize': '512', 'serial': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-sf6-011360241', 'pro
ductID': 'VIRTUAL-DISK', 'vendorID': 'IET', 'capacity': '107374182400', 'pathstatus': [{'physdev': 'sdb', 'state': 'active', 'type': 'iSCSI', 'lun': '1'}], 'pvUUID': ''}, {'status': 'used', 'fwrev': '', 'vgUUID': '', 'pathlist': [], 'lo
gicalblocksize': '', 'devtype': '', 'physicalblocksize': '', 'serial': '', 'GUID': '1Dafna-sf5-011359900', 'productID': '', 'vendorID': '', 'capacity': '107374182400', 'pathstatus': [], 'pvUUID': ''}, {'status': 'used', 'fwrev': '0001',
 'vgUUID': '', 'pathlist': [{'connection': '10.35.64.10', 'iqn': 'Dafna-sf6-02', 'portal': '1', 'port': '3260', 'initiatorname': 'default'}], 'logicalblocksize': '512', 'devtype': 'iSCSI', 'physicalblocksize': '512', 'serial': 'SIET_VIR
TUAL-DISK', 'GUID': '1Dafna-sf6-021360241', 'productID': 'VIRTUAL-DISK', 'vendorID': 'IET', 'capacity': '107374182400', 'pathstatus': [{'physdev': 'sdc', 'state': 'active', 'type': 'iSCSI', 'lun': '1'}], 'pvUUID': ''}, {'status': 'used'
, 'fwrev': '', 'vgUUID': '', 'pathlist': [], 'logicalblocksize': '', 'devtype': '', 'physicalblocksize': '', 'serial': '', 'GUID': '1Dafna-sf5-021359900', 'productID': '', 'vendorID': '', 'capacity': '107374182400', 'pathstatus': [], 'p
vUUID': ''}, {'status': 'used', 'fwrev': '0001', 'vgUUID': '', 'pathlist': [{'connection': '10.35.64.10', 'iqn': 'Dafna-sf6-03', 'portal': '1', 'port': '3260', 'initiatorname': 'default'}], 'logicalblocksize': '512', 'devtype': 'iSCSI',
 'physicalblocksize': '512', 'serial': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-sf6-031360241', 'productID': 'VIRTUAL-DISK', 'vendorID': 'IET', 'capacity': '107374182400', 'pathstatus': [{'physdev': 'sdd', 'state': 'active', 'type': 'iSCSI'
, 'lun': '1'}], 'pvUUID': ''}, {'status': 'used', 'fwrev': '0001', 'vgUUID': '', 'pathlist': [{'connection': '10.35.64.10', 'iqn': 'Dafna-New1', 'portal': '1', 'port': '3260', 'initiatorname': 'default'}], 'logicalblocksize': '512', 'de
vtype': 'iSCSI', 'physicalblocksize': '512', 'serial': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-New11360241', 'productID': 'VIRTUAL-DISK', 'vendorID': 'IET', 'capacity': '53687091200', 'pathstatus': [{'physdev': 'sde', 'state': 'active', 't
ype': 'iSCSI', 'lun': '1'}], 'pvUUID': ''}, {'status': 'used', 'fwrev': '0001', 'vgUUID': '', 'pathlist': [{'connection': '10.35.64.10', 'iqn': 'Dafna-New2', 'portal': '1', 'port': '3260', 'initiatorname': 'default'}], 'logicalblocksize
': '512', 'devtype': 'iSCSI', 'physicalblocksize': '512', 'serial': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-New21360241', 'productID': 'VIRTUAL-DISK', 'vendorID': 'IET', 'capacity': '53687091200', 'pathstatus': [{'physdev': 'sdf', 'state':
 'active', 'type': 'iSCSI', 'lun': '1'}], 'pvUUID': ''}, {'status': 'used', 'fwrev': '0001', 'vgUUID': '', 'pathlist': [{'connection': '10.35.64.10', 'iqn': 'Dafna-New3', 'portal': '1', 'port': '3260', 'initiatorname': 'default'}], 'log
icalblocksize': '512', 'devtype': 'iSCSI', 'physicalblocksize': '512', 'serial': 'SIET_VIRTUAL-DISK', 'GUID': '1Dafna-New31360241', 'productID': 'VIRTUAL-DISK', 'vendorID': 'IET', 'capacity': '53687091200', 'pathstatus': [{'physdev': 's
dg', 'state': 'active', 'type': 'iSCSI', 'lun': '1'}], 'pvUUID': ''}]}
Comment 2 Dafna Ron 2013-02-07 09:37:27 EST
creation of the domain with force will also fail on same issue.
Comment 3 Yeela Kaplan 2013-02-07 11:46:29 EST
http://gerrit.ovirt.org/#/c/11852/1
Comment 4 Yeela Kaplan 2013-02-07 11:46:55 EST
(In reply to comment #3)
> http://gerrit.ovirt.org/#/c/11852/1

Change-Id: Ia5428d3d8b1d0b10b083b663b12d3a6ceb7e3e69
Comment 6 Elad 2013-02-21 11:29:44 EST
I checked on SF7. I tried to create a new domain with a lun that has "-" and "_" in it's name and I failed:  

Error while executing action New SAN Storage Domain: Physical device initialization failed. Check that the device is empty. Please remove all files and partitions from the device.
Comment 7 Ayal Baron 2013-02-24 01:20:42 EST
(In reply to comment #6)
> I checked on SF7. I tried to create a new domain with a lun that has "-" and
> "_" in it's name and I failed:  
> 
> Error while executing action New SAN Storage Domain: Physical device
> initialization failed. Check that the device is empty. Please remove all
> files and partitions from the device.

This has nothing to do with this bug.  The LUN you used is just not empty.
I would show the excerpts from the logs, but there are no new logs attached...
Comment 8 Elad 2013-02-24 02:53:04 EST
(In reply to comment #7)
> (In reply to comment #6)
> > I checked on SF7. I tried to create a new domain with a lun that has "-" and
> > "_" in it's name and I failed:  
> > 
> > Error while executing action New SAN Storage Domain: Physical device
> > initialization failed. Check that the device is empty. Please remove all
> > files and partitions from the device.
> 
> This has nothing to do with this bug.  The LUN you used is just not empty.
> I would show the excerpts from the logs, but there are no new logs
> attached...

please see attached logs.
I know that the lun was not empty, but VDSM has a sepcial treatment for it when it passes the --force option (as you can see in the attached logs).
the failure related to the bug since the lun is still ignored by the filter.

Thread-223544::DEBUG::2013-02-24 07:49:14,819::task::568::TaskManager.Task::(_updateState) Task=`35dc0da6-9d66-4658-9dbe-4672a9197854`::moving from state init -> state preparing
Thread-223544::INFO::2013-02-24 07:49:14,819::logUtils::37::dispatcher::(wrapper) Run and protect: createVG(vgname='c8d57bc6-0984-4e1c-9b05-cb66e49fc574', devlist=['1elad-1_11361462'], force=True, options=None)
Thread-223544::DEBUG::2013-02-24 07:49:14,822::misc::83::Storage.Misc.excCmd::(<lambda>) '/usr/bin/sudo -n /sbin/lvm pvcreate --config " devices { preferred_names = [\\"^/dev/mapper/\\"] ignore_suspended_devices=1
 write_cache_state=0 disable_after_error_count=3 filter = [ \'a%1Elad1360756|1EladNewLUN1360769|1EladNewLUNExtend1360832|1elad\\\\x2d19\\\\x2e2\\\\x2e13\\\\x2d11361287|1elad\\\\x2d19\\\\x2e2\\\\x2e131361284|1elad\
\\\x2d1_11361462|1elad19\\\\x2e21361289%\', \'r%.*%\' ] }  global {  locking_type=1  prioritise_write_locks=1  wait_for_locks=1 }  backup {  retain_min = 50  retain_days = 0 } " -y -ff --metadatasize 128m --metada
tacopies 2 --metadataignore y /dev/mapper/1elad-1_11361462' (cwd None)
Thread-223544::DEBUG::2013-02-24 07:49:14,973::misc::83::Storage.Misc.excCmd::(<lambda>) FAILED: <err> = '  Device /dev/mapper/1elad-1_11361462 not found (or ignored by filtering).\n'; <rc> = 5
Thread-223544::DEBUG::2013-02-24 07:49:14,976::lvm::480::OperationMutex::(_invalidatepvs) Operation 'lvm invalidate operation' got the operation mutex
Thread-223544::DEBUG::2013-02-24 07:49:14,976::lvm::483::OperationMutex::(_invalidatepvs) Operation 'lvm invalidate operation' released the operation mutex
Thread-223544::ERROR::2013-02-24 07:49:14,977::lvm::688::Storage.LVM::(_initpvs) pvcreate failed with rc=5
Thread-223544::ERROR::2013-02-24 07:49:14,977::lvm::689::Storage.LVM::(_initpvs) [], ['  Device /dev/mapper/1elad-1_11361462 not found (or ignored by filtering).']
Thread-223544::ERROR::2013-02-24 07:49:14,977::task::833::TaskManager.Task::(_setError) Task=`35dc0da6-9d66-4658-9dbe-4672a9197854`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 840, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/logUtils.py", line 38, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/storage/hsm.py", line 1949, in createVG
    (force.capitalize() == "True")))
  File "/usr/share/vdsm/storage/lvm.py", line 868, in createVG
    _initpvs(pvs, metadataSize, force)
  File "/usr/share/vdsm/storage/lvm.py", line 690, in _initpvs
    raise se.PhysDevInitializationError(str(devices))
PhysDevInitializationError: Failed to initialize physical device: ("['/dev/mapper/1elad-1_11361462']"
Comment 9 Yeela Kaplan 2013-02-24 04:43:41 EST
Results for SF6.
Waiting for SF7 results.
Comment 10 Elad 2013-02-24 06:21:37 EST
Checked on SF8. I was manage to create a new iSCSI domain with "-" and "_" in the lun name.



Run and protect: createVG(vgname='3ee0b491-b4c8-4adb-aa39-9dc7c23d2829', devlist=['1elad-1_11361462'], force=False, options=None)
Thread-83::DEBUG::2013-02-24 12:54:02,778::misc::83::Storage.Misc.excCmd::(<lambda>) '/usr/bin/sudo -n /sbin/lvm pvcreate --config " devices { preferred_names = [\\"^/dev/mapper/\\"] ignore_suspended_devices=1 wri
te_cache_state=0 disable_after_error_count=3 filter = [ \'a%1elad-1_11361462%\', \'r%.*%\' ] }  global {  locking_type=1  prioritise_write_locks=1  wait_for_locks=1 }  backup {  retain_min = 50  retain_days = 0 }
" --metadatasize 128m --metadatacopies 2 --metadataignore y /dev/mapper/1elad-1_11361462' (cwd None)
Comment 12 Ayal Baron 2013-03-10 04:59:51 EDT
*** Bug 703739 has been marked as a duplicate of this bug. ***
Comment 13 Cheryn Tan 2013-03-14 01:45:37 EDT
Hi Yeela and Ayal, 

If I understand correctly the issue described here is similar to that of bug 876575. 

I propose to remove this bug off the release note queue, please let me know if you think both bugs should actually be documented.

Thank you,
Cheryn
Comment 14 Ayal Baron 2013-03-14 01:58:23 EDT
(In reply to comment #13)
> Hi Yeela and Ayal, 
> 
> If I understand correctly the issue described here is similar to that of bug
> 876575. 
> 
> I propose to remove this bug off the release note queue, please let me know
> if you think both bugs should actually be documented.
> 
> Thank you,
> Cheryn

Correct.  You can unify the notes to a single note stating that we now support the above characters as well as spaces and unicode etc.
Comment 15 Cheryn Tan 2013-03-14 02:13:36 EDT
Thanks for the prompt reply Ayal! Changing the doc type to Bug Fix so it doesn't show up in the release note filters.
Comment 16 Itamar Heim 2013-06-11 04:58:11 EDT
3.2 has been released
Comment 17 Itamar Heim 2013-06-11 04:58:22 EDT
3.2 has been released
Comment 18 Itamar Heim 2013-06-11 04:58:22 EDT
3.2 has been released
Comment 19 Itamar Heim 2013-06-11 05:00:12 EDT
3.2 has been released
Comment 20 Itamar Heim 2013-06-11 05:29:45 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.