Bug 908778 - Change PM delay for Start/Stop operations
Change PM delay for Start/Stop operations
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.2.0
Assigned To: Eli Mesika
Tareq Alayan
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-02-07 08:53 EST by Eli Mesika
Modified: 2016-02-10 14:16 EST (History)
11 users (show)

See Also:
Fixed In Version: sf8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11876 None None None Never

  None (edit)
Description Eli Mesika 2013-02-07 08:53:50 EST
Description of problem:
currently when a Start/Stop operation is invoked, the default number of retries is 3 while the delay between retries is 60 sec.
That means that if when we initially check the status after a Start/Stop operation it does not reach on/off status we will have to wait 60 seconds to sample the status again

A shorter delay of 10 seconds while keeping the total default waiting time untouched (means modifying default number of retries to 18 will improve user experience in PM operations 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run a system with 2 Hosts h1 & h2 , h1 has PM
2.turn vdsmd down on h1
3.h1 will be fenced by h2
4.sometimes it will take more than a minute to update h1 status
  
Actual results:
Status change is delay due to improper value of delay between retries

FenceStartStatusDelayBetweenRetriesInSec=60
FenceStartStatusRetries=3
FenceStopStatusDelayBetweenRetriesInSec=60
FenceStopStatusRetries=3

Expected results:

Status should be changed ASAP
Default config values should be changed to 

FenceStartStatusDelayBetweenRetriesInSec=10
FenceStartStatusRetries=18
FenceStopStatusDelayBetweenRetriesInSec=10
FenceStopStatusRetries=18


Additional info:
Comment 1 Eli Mesika 2013-02-10 09:19:32 EST
fixed in commit : 17aafef
Comment 3 Itamar Heim 2013-06-11 05:25:30 EDT
3.2 has been released
Comment 4 Itamar Heim 2013-06-11 05:30:21 EDT
3.2 has been released
Comment 5 Itamar Heim 2013-06-11 05:45:46 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.