Bug 9088 - anaconda hangs with Python traceback just before installing RPMs
anaconda hangs with Python traceback just before installing RPMs
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-02 20:46 EST by gward
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 10:38:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description gward 2000-02-02 20:46:05 EST
I'm having trouble upgrading my Red Hat 5.2 system to 6.1, and it
appears to stem from a bug in anaconda.  (I'm using the "updates" disk,
RHEA-45 I think it was.  Downloaded it from updates.redhat.com
yesterday.)

Specifically, after I've gone through most (all?) of the dialogs and am
ready to perform the upgrade, anaconda does the "Rebuilding RPM
database" thing, and then it does the "Preparing for upgrade" thing (I
think that's the wording -- the one with the progress bar which takes
several minutes), and then it hangs after the progress bar reaches the
finish line.  It just stops.  Dead.  Nothing.

So I flipped over to VC 1 and there was a Python traceback on the
screen.  Due to the obviously limited resources in the install
environment, I was unable to cut 'n paste the whole traceback -- but I
scribbled down the essentials and here they are:

   threading.py line 376
...program.py line 16
...todo.py line 1547
   TypeError: "illegal argument for built-in operation"

Here's line 1547 in todo.py on the "updates" floppy:

  1547                  prob = "%-15s %d %c\n" % (mount, need, suffix)

The only thing that can be causing that exception on line 1547 is the %d
specifier in the format string; looks like anything that can't be
converted to an integer raises that TypeError.  So presumably 'need' is
wrong, ie. not an integer.  Unfortunately I can't figure out from
reading the code under what circumstances 'need' would be not an integer
(or something that can be converted to an integer).

I also had exactly the same problem with the stock Red Hat 6.1 CD-ROM
and boot disk, although the traceback was at a different point in
todo.py.

Also, when I killed the anaconda process (Ctrl-C in VC 1), I got a
kernel panic, something about "unable to remout root partition" --
meaning my root partition was not cleanly unmounted.  Yuck!

The destination system is a slightly souped-up Red Hat 5.2; I made the
necessary upgrades to run the 2.2 kernel, and ditched your sendmail RPM
in favour of building my own qmail.  Those are about the only major
changes, though.
Comment 1 Matt Wilson 2000-02-09 02:07:59 EST
It looks like you don't have enough disk space to complete the upgrade.  Try
freeing some up.  I've fixed the error in disk space shortage reporting in our
next release.

Note You need to log in before you can comment on or make changes to this bug.