Bug 908986 - When trying to download a kernel-debuginfo package by `stap-prep` for using systemtap. Yum throws a Python Exception.
Summary: When trying to download a kernel-debuginfo package by `stap-prep` for using s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 18
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-08 00:39 UTC by Prudhvi Krishna Surapaneni
Modified: 2013-02-27 02:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-27 02:31:04 UTC


Attachments (Terms of Use)

Description Prudhvi Krishna Surapaneni 2013-02-08 00:39:12 UTC
Description of problem:

When trying to download a kernel-debuginfo package by `stap-prep` for using systemtap. Yum throws a Python Exception.

Traceback (most recent call last):
  File "/bin/yumdownloader", line 273, in <module>
    util = YumDownloader()
  File "/bin/yumdownloader", line 73, in __init__
    self.main()
  File "/bin/yumdownloader", line 98, in main
    self.exit_code = self.downloadPackages(opts)
  File "/bin/yumdownloader", line 206, in downloadPackages
    rpmfn = os.path.basename(pkg.remote_path)
AttributeError: TransactionMember instance has no attribute 'remote_path'
problem downloading rpm(s) kernel-debuginfo-3.7.5-201.fc18.x86_64

 

Version-Release number of selected component (if applicable):

yum: yum-3.4.3-48.fc18.noarch
rpm: rpm-4.10.2-1.fc18.x86_64
systetap: systemtap-2.0-6.fc18.x86_64
kernel: 3.7.5-201.fc18.x86_64


How reproducible:
Everytime


Steps to Reproduce:
1. Download, systemtap systemtap-runtime systemtap-client systemtap-devel systemtap-sdt-devel
2. run stap-devel
  
Actual results:

[root@beta-tauri ~]# stap-prep 
Need to install the following packages:
kernel-debuginfo-3.7.5-201.fc18.x86_64
--> Running transaction check
---> Package kernel-debuginfo.x86_64 0:3.7.5-201.fc18 will be installed
--> Processing Dependency: kernel-debuginfo-common-x86_64 = 3.7.5-201.fc18 for package: kernel-debuginfo-3.7.5-201.fc18.x86_64
--> Running transaction check
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.7.2-204.fc18 will be updated
--> Processing Dependency: kernel-debuginfo-common-x86_64 = 3.7.2-204.fc18 for package: kernel-debuginfo-3.7.2-204.fc18.x86_64
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.7.5-201.fc18 will be an update
--> Running transaction check
---> Package kernel-debuginfo.x86_64 0:3.7.2-204.fc18 will be updated
---> Package kernel-debuginfo.x86_64 0:3.7.6-201.fc18 will be an update
--> Processing Dependency: kernel-debuginfo-common-x86_64 = 3.7.6-201.fc18 for package: kernel-debuginfo-3.7.6-201.fc18.x86_64
--> Running transaction check
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.7.2-204.fc18 will be updated
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.7.2-204.fc18 will be updated
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.7.5-201.fc18 will be an update
--> Processing Dependency: kernel-debuginfo-common-x86_64 = 3.7.5-201.fc18 for package: kernel-debuginfo-3.7.5-201.fc18.x86_64
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.7.6-201.fc18 will be an update
--> Finished Dependency Resolution
Traceback (most recent call last):
  File "/bin/yumdownloader", line 273, in <module>
    util = YumDownloader()
  File "/bin/yumdownloader", line 73, in __init__
    self.main()
  File "/bin/yumdownloader", line 98, in main
    self.exit_code = self.downloadPackages(opts)
  File "/bin/yumdownloader", line 206, in downloadPackages
    rpmfn = os.path.basename(pkg.remote_path)
AttributeError: TransactionMember instance has no attribute 'remote_path'
problem downloading rpm(s) kernel-debuginfo-3.7.5-201.fc18.x86_64


Expected results:

Downloading and installing kernel-debuginfo-`uname -r`


Additional info:
I have fedora-debuginfo repository enabled in my yum.repos.d/fedora.repo

Comment 1 Zdeněk Pavlas 2013-02-08 08:28:25 UTC
Reproduced, I hope I'll fix it soon.. This bug was probably introduced when switching do Yum's downloader.  Strangely, without the --resolve option (should be transparent to download code), everything runs fine.

Comment 2 Fedora Update System 2013-02-08 09:17:59 UTC
yum-utils-1.1.31-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-9.fc18

Comment 3 Fedora Update System 2013-02-09 11:25:10 UTC
Package yum-utils-1.1.31-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-utils-1.1.31-9.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2178/yum-utils-1.1.31-9.fc18
then log in and leave karma (feedback).

Comment 4 Prudhvi Krishna Surapaneni 2013-02-11 23:02:30 UTC
Actually, with this update i see other problems in Yum

[root@beta-tauri ~]# stap-prep 
Need to install the following packages:
kernel-debuginfo-3.7.6-201.fc18.x86_64
updates-debuginfo/18/x86_64/metalink                                                                                                                                                                                                                                |  13 kB  00:00:00     
updates-debuginfo                                                                                                                                                                                                                                                   | 3.1 kB  00:00:00     
updates-testing-debuginfo/18/x86_64/metalink                                                                                                                                                                                                                        |  12 kB  00:00:00     
updates-testing-debuginfo                                                                                                                                                                                                                                           | 3.1 kB  00:00:00     
(1/2): updates-debuginfo/primary_db                                                                                                                                                                                                                                 | 357 kB  00:00:00     
(2/2): updates-testing-debuginfo/primary_db                                                                                                                                                                                                                         | 549 kB  00:00:00     
--> Running transaction check
---> Package kernel-debuginfo.x86_64 0:3.7.6-201.fc18 will be installed
--> Processing Dependency: kernel-debuginfo-common-x86_64 = 3.7.6-201.fc18 for package: kernel-debuginfo-3.7.6-201.fc18.x86_64
--> Running transaction check
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.7.2-204.fc18 will be updated
--> Processing Dependency: kernel-debuginfo-common-x86_64 = 3.7.2-204.fc18 for package: kernel-debuginfo-3.7.2-204.fc18.x86_64
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.7.6-201.fc18 will be an update
--> Running transaction check
---> Package kernel-debuginfo.x86_64 0:3.7.2-204.fc18 will be updated
--> Finished Dependency Resolution
Traceback (most recent call last):
  File "/bin/yumdownloader", line 273, in <module>
    util = YumDownloader()
  File "/bin/yumdownloader", line 73, in __init__
    self.main()
  File "/bin/yumdownloader", line 98, in main
    self.exit_code = self.downloadPackages(opts)
  File "/bin/yumdownloader", line 206, in downloadPackages
    rpmfn = os.path.basename(pkg.remote_path)
  File "/usr/lib/python2.7/site-packages/yum/packages.py", line 836, in _remote_path
    return self.relativepath
  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 110, in __getattr__
    val = val[varname] # a lot we should preload at __init__.
ValueError: unknown header tag
problem downloading rpm(s) kernel-debuginfo-3.7.6-201.fc18.x86_64

Prudhvi Krishna Surapaneni.

Comment 5 Fedora Update System 2013-02-13 04:37:17 UTC
yum-utils-1.1.31-9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Zdeněk Pavlas 2013-02-18 14:37:45 UTC
This seems to be an old, unrelated bug.  "yumdownloader --resolve" fails when one of the dependent packages is an update.  AIUI, this never worked.  Fixed upstream.

Comment 7 Fedora Update System 2013-02-18 16:06:40 UTC
yum-utils-1.1.31-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-10.fc18

Comment 8 Fedora Update System 2013-02-19 01:24:02 UTC
Package yum-utils-1.1.31-10.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-utils-1.1.31-10.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2677/yum-utils-1.1.31-10.fc18
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-02-27 02:31:07 UTC
yum-utils-1.1.31-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.