Bug 909026 - Unexpected error when trying to download config file when project-type not set on version
Unexpected error when trying to download config file when project-type not se...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: WebSite (Show other bugs)
development
Unspecified Unspecified
unspecified Severity high
: ---
: 2.2
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 00:14 EST by David Mason
Modified: 2013-11-26 22:34 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.2-SNAPSHOT (20130215-1232)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:24:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2013-02-08 00:14:04 EST
Description of problem:
When trying to download config file for a version that does not have a specific project type set, an error occurs and it is not possible to download the config file.

Version-Release number of selected component (if applicable):
2.2-SNAPSHOT (20130208-1232)

How reproducible:
Always


Steps to Reproduce:
1.Sign in and navigate to any version that has not had projectType set
  (note that the projectType may be set on the parent project)
2.Click "config file"
  
Actual results:
Shows error page with "Unexpected error. Please try again. [ Request: /error.seam?cid=48 ]"

Expected results:
Config file can download regardless of projectType setting. projectType setting on project should be inherited by version

Additional info:
This appears to be caused by the code that generates the config file assuming that there will always be a project type setting on each version, and a lack of inheriting project type properly from project to version
Comment 1 Alex Eng 2013-02-11 22:08:34 EST
Fixed in Zanata-server 2.2

See
https://github.com/zanata/zanata/commit/7973d5db338578e89fa6b56576cf9f3b75a2526c
Comment 2 Ding-Yi Chen 2013-02-15 02:44:45 EST
VERIFIED with Zanata version 2.2-SNAPSHOT (20130215-1232)
Comment 3 Sean Flanigan 2013-11-26 22:14:22 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 4 Sean Flanigan 2013-11-26 22:16:09 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 5 Sean Flanigan 2013-11-26 22:17:45 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 6 Sean Flanigan 2013-11-26 22:24:04 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 7 Sean Flanigan 2013-11-26 22:32:21 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 8 Sean Flanigan 2013-11-26 22:34:38 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.

Note You need to log in before you can comment on or make changes to this bug.