Bug 909083 - Missing LSB header in redis init script
Summary: Missing LSB header in redis init script
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: redis
Version: el6
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nathan Scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 909082 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-08 08:11 UTC by nicolas.perrenoud
Modified: 2017-09-04 17:48 UTC (History)
4 users (show)

Fixed In Version: redis-3.2.10-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-04 17:48:39 UTC


Attachments (Terms of Use)

Description nicolas.perrenoud 2013-02-08 08:11:05 UTC
Description of problem:

The init script of redis /etc/init.d/redis is missing an LSB init header. This can cause issues when other servers depend on redis being startet at bootup (in my case, gitlab).

Version-Release number of selected component (if applicable): 2.4.10

Solution: Please add the following (or similar) header to /etc/init.d/redis

### BEGIN INIT INFO
# Provides:          redis-server
# Required-Start:    $local_fs $remote_fs $network $syslog
# Required-Stop:     $local_fs $remote_fs $network $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: A persistent key-value database
# Description:       A persistent key-value database
### END INIT INFO

Comment 1 nicolas.perrenoud 2013-02-08 09:42:07 UTC
*** Bug 909082 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2017-08-18 01:12:06 UTC
redis-3.2.10-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-0ad4c424f0

Comment 3 Fedora Update System 2017-08-18 20:18:49 UTC
redis-3.2.10-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-0ad4c424f0

Comment 4 Fedora Update System 2017-09-04 17:48:39 UTC
redis-3.2.10-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.