Bug 909097 - [RHEVM] [upgrade] [backend] upgrade si26.1 to si27 failed - OSError: [Errno 2] No such file or directory
[RHEVM] [upgrade] [backend] upgrade si26.1 to si27 failed - OSError: [Errno 2...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.2
x86_64 Linux
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Eli Mesika
Jiri Belka
infra
: Regression, TestBlocker, ZStream
: 909688 (view as bug list)
Depends On:
Blocks: 910022 915537
  Show dependency treegraph
 
Reported: 2013-02-08 03:52 EST by Martin Pavlik
Modified: 2016-02-10 14:32 EST (History)
13 users (show)

See Also:
Fixed In Version: sf7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 910022 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt-engine-upgrade_2013_02_08_09_28_04.log.tar (2.40 KB, application/x-xz)
2013-02-08 03:52 EST, Martin Pavlik
no flags Details
sosreport-LogCollector-admin-20130208094544-37c6.tar (519.93 KB, application/x-xz)
2013-02-08 03:53 EST, Martin Pavlik
no flags Details
rhevm-upgrade-strace.tar.xz (14.64 MB, application/x-xz)
2013-02-08 03:54 EST, Martin Pavlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11917 None None None Never

  None (edit)
Description Martin Pavlik 2013-02-08 03:52:24 EST
Created attachment 694990 [details]
ovirt-engine-upgrade_2013_02_08_09_28_04.log.tar

Description of problem:
upgrade si26.1 to si27 failed

Version-Release number of selected component (if applicable):
si27

How reproducible:
100%

Steps to Reproduce:
1. have installation of si26.1 (just emty rhevm)
2. update rhevm-setup
3. run rhevm-upgrade
  
Actual results:

2013-02-08 09:36:09::ERROR::rhevm-upgrade::1498::root:: Traceback (most recent call last):
  File "/usr/bin/rhevm-upgrade", line 1491, in <module>
    main(options)
  File "/usr/bin/rhevm-upgrade", line 1342, in main
    checkRunningTasks()
  File "/usr/bin/rhevm-upgrade", line 1069, in checkRunningTasks
    if zombie_tasks_found():
  File "/usr/bin/rhevm-upgrade", line 936, in zombieTasksFound
    msg="Can't get zombie async tasks",
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 363, in execCmd
    env=env,
  File "/usr/lib64/python2.6/subprocess.py", line 639, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1228, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Expected results:
successfull upgrade

Additional info:
upgrade log
log collector
strace of rhevm-upgrade 
attached
Comment 1 Martin Pavlik 2013-02-08 03:53:13 EST
Created attachment 694991 [details]
sosreport-LogCollector-admin-20130208094544-37c6.tar
Comment 2 Martin Pavlik 2013-02-08 03:54:38 EST
Created attachment 694993 [details]
rhevm-upgrade-strace.tar.xz
Comment 3 Yaniv Kaul 2013-02-10 09:44:23 EST
*** Bug 909688 has been marked as a duplicate of this bug. ***
Comment 7 Jiri Belka 2013-03-21 08:07:30 EDT
ok, sf7.
Comment 8 Itamar Heim 2013-06-11 04:29:35 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 04:29:39 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 04:32:08 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.