This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 909161 - ipa-client-install failed to fall over to replica with master down
ipa-client-install failed to fall over to replica with master down
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.4
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
: ZStream
Depends On: 905626 910557
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 07:31 EST by Jiri Pallich
Modified: 2013-03-07 03:39 EST (History)
9 users (show)

See Also:
Fixed In Version: ipa-3.0.0-26.el6_4
Doc Type: Bug Fix
Doc Text:
The Identity Management client enrollment "ipa-client-install" command would fail to enroll a client if any of the Identity Management masters were unavailable during enrollment. The client installer now tries all servers, either auto-discovered from DNS or passed via the "--server" option on the command line, until it finds one that is available and enrolls it in that one. Now, the Identity Management client enrollment "ipa-client-install" command functions normally.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-07 03:39:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Pallich 2013-02-08 07:31:15 EST
This bug has been copied from bug #905626 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 5 Scott Poore 2013-02-19 14:02:54 EST
Verified.

Version ::

ipa-client-3.0.0-26.el6_4.1.x86_64

Automated Test Results ::

Note that the automation flags it as original bz 905626 which this was cloned from.

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: ipa-client-install-37- [Positive] Install with MASTER down, SLAVE up [BZ 905626]
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [19:48:31] ::  sssd.conf for testing BZ 819982 does not exists
Shutting down ntpd: [FAILED]
:: [   PASS   ] :: Running 'service ntpd stop'
Password for admin@TESTRELM.COM: 
ipa: ERROR: hp-dl380pgen8-02-vm-2.testrelm.com: host not found
:: [   PASS   ] :: Running 'ssh root@10.16.96.83 "echo PASSWORD|kinit admin;ipa host-del hp-dl380pgen8-02-vm-2.testrelm.com"'

MARK-LWD-LOOP -- 2013-02-18 19:49:04 --
:: [   PASS   ] :: Running 'sleep 60'
Warning: Permanently added 'nightcrawler.testrelm.com' (RSA) to the list of known hosts.
Stopping pki-ca: [  OK  ]
Stopping httpd: [  OK  ]
Stopping ipa_memcached: [  OK  ]
Stopping named: .[  OK  ]
Stopping Kerberos 5 Admin Server: [  OK  ]
Stopping Kerberos 5 KDC: [  OK  ]
Shutting down dirsrv: 
    PKI-IPA...[  OK  ]
    TESTRELM-COM...[  OK  ]
Stopping CA Service
Stopping HTTP Service
Stopping MEMCACHE Service
Stopping DNS Service
Stopping KPASSWD Service
Stopping KDC Service
Stopping Directory Service
:: [   PASS   ] :: Stop MASTER IPA server
:: [19:50:20] ::  EXECUTING: ipa-client-install --domain=testrelm.com --realm=TESTRELM.COM  -p admin -w PASSWORD --unattended
Discovery was successful!
Hostname: hp-dl380pgen8-02-vm-2.testrelm.com
Realm: TESTRELM.COM
DNS Domain: testrelm.com
IPA Server: cloud-qe-7.testrelm.com
BaseDN: dc=testrelm,dc=com
Synchronizing time with KDC...
Enrolled in IPA realm TESTRELM.COM
Created /etc/ipa/default.conf
New SSSD config will be created
Configured /etc/sssd/sssd.conf
Configured /etc/krb5.conf for IPA realm TESTRELM.COM
trying https://cloud-qe-7.testrelm.com/ipa/xml
Adding SSH public key from /etc/ssh/ssh_host_dsa_key.pub
Adding SSH public key from /etc/ssh/ssh_host_rsa_key.pub
Forwarding 'host_mod' to server u'https://cloud-qe-7.testrelm.com/ipa/xml'
SSSD enabled
Configured /etc/openldap/ldap.conf
NTP enabled
Configured /etc/ssh/ssh_config
Configured /etc/ssh/sshd_config
Client configuration complete.

:: [   PASS   ] :: Installing ipa client and configuring - with all params
:: [   PASS   ] :: File '/var/log/ipaclient-install.log' should not contain 'Can't contact LDAP server'
:: [   PASS   ] :: File '/var/log/ipaclient-install.log' should not contain 'Failed to verify that.*is an IPA Server'
:: [   PASS   ] :: BZ 905626 not found
:: [19:51:21] ::  Backing up and submitting /var/log/ipaclient-install.log
Starting dirsrv: 
    PKI-IPA...[  OK  ]
    TESTRELM-COM...[  OK  ]
Starting Kerberos 5 KDC: [  OK  ]
Starting Kerberos 5 Admin Server: [  OK  ]
Starting named: [  OK  ]
Starting ipa_memcached: [  OK  ]
Starting httpd: [  OK  ]
Starting pki-ca: [  OK  ]
Starting Directory Service
Starting KDC Service
Starting KPASSWD Service
Starting DNS Service
Starting MEMCACHE Service
Starting HTTP Service
Starting CA Service
:: [   PASS   ] :: Start MASTER IPA server
Comment 7 errata-xmlrpc 2013-03-07 03:39:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0606.html

Note You need to log in before you can comment on or make changes to this bug.