Bug 90924 - USB camera worked in RH 7.3, stopped working for 8 and 9 on Asus A7V333, Athlon XP 1800+
Summary: USB camera worked in RH 7.3, stopped working for 8 and 9 on Asus A7V333, Athl...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-15 13:43 UTC by Ignacio Valdes
Modified: 2007-04-18 16:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 15:40:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg out. (10.09 KB, text/plain)
2003-06-03 12:35 UTC, Ignacio Valdes
no flags Details
Dmesg out. (8.55 KB, text/plain)
2003-06-04 13:09 UTC, Ignacio Valdes
no flags Details
Dmesg out for 2.4.20-18.9. (7.93 KB, text/plain)
2003-06-05 03:13 UTC, Ignacio Valdes
no flags Details
devices file (2.04 KB, text/plain)
2003-06-06 02:09 UTC, Ignacio Valdes
no flags Details
dmesg for 2.4.20-18.9smp (14.04 KB, text/plain)
2003-06-07 13:42 UTC, andrew
no flags Details

Description Ignacio Valdes 2003-05-15 13:43:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
USB camera worked in RH 7.3, stopped working for 8 and 9 on Asus A7V333, Athlon
XP 1800+ My pen drive does not work also. mount /dev/sda1 returns invalid block
device, and checking of logs for hot plugging reveals no detection of hot
plugging or un-plugging. Hot plugging works on another OS dual-booted for this
machine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start computer.
2. Plug in USB device.
3.
    

Actual Results:  Nothing happens.

Expected Results:  Should detect USB devices and enable them to be mounted.

Additional info:

Comment 1 Pete Zaitcev 2003-06-03 03:22:14 UTC
Please attach the dmesg output, taken after an attempt to access the storage
(pen or camera). Please do not drop it into the comments box.



Comment 2 Ignacio Valdes 2003-06-03 12:35:40 UTC
Created attachment 92103 [details]
Dmesg out.

Here's dmesg out after plugging in my pen drive.

Comment 3 Pete Zaitcev 2003-06-03 20:49:22 UTC
Thanks, great dmesg.

Please do two things for me.
1. Remove ehci-hcd alias from /etc/modules.conf. I figure, if the camera
   worked before (when we didn't ship ehci-hcd), you should not be using it now.
2. If that fails, update kernel to 2.4.20-18.9. There were issues with usb-uhci.

BTW, the -bigmem kernel is only needed for 16GB boxes. You lose some
performance when running it on a 256MB box. This is not relevant to our
USB problems, just noting in passing.


Comment 4 Ignacio Valdes 2003-06-04 03:37:15 UTC
I took ehci-hcd alias from /etc/modules.conf and upgraded the kernel to
2.4.20-18.9, but there doesn't appear to be a change. mount /dev/sda1 /mnt/foo
yields 'mount: /dev/sda1 is not a valid block device' Thanks -- IV

Comment 5 Pete Zaitcev 2003-06-04 03:43:23 UTC
I'd like to see the dmesg again, taken after an attempt to access /dev/sda
but without ehci. In the firs dmesg ehci-hcd and usb-uhci seems to conflict.
I know that it fails anyway, but it would be something different now.
Please attach it as before. Thanks.


Comment 6 Ignacio Valdes 2003-06-04 13:09:07 UTC
Created attachment 92134 [details]
Dmesg out.

New dmesg with new kernel. -- IV

Comment 7 Pete Zaitcev 2003-06-04 16:23:15 UTC
You attached a dmesg for 2.4.20-8, while I asked 2.4.20-18.


Comment 8 Ignacio Valdes 2003-06-05 03:13:18 UTC
Created attachment 92151 [details]
Dmesg out for 2.4.20-18.9.

Oops, here you go. -- IV

Comment 9 Pete Zaitcev 2003-06-05 20:26:20 UTC
OK, at least your interrupts are routed right, that's encouraging.
May I see the /proc/bus/usb/devices?


Comment 10 Ignacio Valdes 2003-06-06 02:09:55 UTC
Created attachment 92195 [details]
devices file

Here you go.

Comment 11 andrew 2003-06-07 13:40:30 UTC
My USB mass storage camera worked in RH 7.2, hangs system in RH9.

Description of problem:
About 15 sec after connecting camera, KDE desktop freezes. Only way to 
recover is turn off power and reboot. 

Same problem in both 2.4.20-13.9smp  and  2.4.20-18.9smp
The camera used to work with RH7.2, kernel 2.4.18-17.7x.


Output from /var/log/messages when the cammera is connected....

kernel: hub.c: new USB device 00:1f.4-2, assigned address 2
kernel: usb.c: USB device 2 (vend/prod 0x4c8/0x726) is not claimed by any active
driver.
/etc/hotplug/usb.agent: Setup usb-storage for USB product 4c8/726/100
kernel: Initializing USB Mass Storage driver...
kernel: usb.c: registered new driver usb-storage
kernel: scsi2 : SCSI emulation for USB Mass Storage devices
kernel:   Vendor: Konica    Model: KD-400Z           Rev: 1.00
kernel:   Type:   Direct-Access                      ANSI SCSI revision: 02
kernel: Attached scsi removable disk sdb at scsi2, channel 0, id 0, lun 0
kernel: SCSI device sdb: 124065 512-byte hdwr sectors (64 MB)
kernel: sdb: Write Protect is off
kernel:  sdb: sdb1
kernel: USB Mass Storage support registered.
kernel: usb-uhci.c: interrupt, status 3, frame# 996

Output following disconnection of camera...
 
kernel: usb-uhci.c: interrupt, status 2, frame# 624
kernel: usb.c: USB disconnect on device 00:1f.4-2 address 2
kernel: hub.c: USB device not accepting new address (error=-110)




Comment 12 andrew 2003-06-07 13:42:02 UTC
Created attachment 92236 [details]
dmesg for 2.4.20-18.9smp

Comment 13 andrew 2003-06-11 01:06:22 UTC
The same camera that hangs my RH9 system works with RH8, kernel 2.4.20-18.8 
(the RH8 system is a different computer, not SMP).
Can provide further details if needed.



Comment 14 Pete Zaitcev 2004-08-19 23:25:11 UTC
Ignacio, how are FC1 and/or FC2?


Comment 15 Bugzilla owner 2004-09-30 15:40:55 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/


Comment 16 Dimitri Papadopoulos 2004-11-21 15:26:55 UTC
See also bug #107248 as it seems to be related.



Note You need to log in before you can comment on or make changes to this bug.