Bug 90941 - %_netsharedpath breaks filesystem-package
%_netsharedpath breaks filesystem-package
Status: CLOSED DUPLICATE of bug 52725
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-15 13:13 EDT by Enrico Scholz
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2003-05-15 13:13:48 EDT
Description of problem:

When using %_netsharedpath, the installation of the filesystem packages fails:

| # D=/tmp/X
| #
U=http://wftp.tu-chemnitz.de/pub/linux/redhat-ftp/redhat/linux/rawhide/i386/RedHat/RPMS/
| # mkdir -p $D $D/var/tmp
| # rpm -r $D --initdb
| # echo '%_netsharedpath /usr/share/doc' >/etc/rpm/macros
| # rpm -r $D -U ${U}setup-2.5.26-1.noarch.rpm  
| # rpm -r $D -U ${U}filesystem-2.2.1-3.i386.rpm
| error: unpacking of archive failed on file /usr/X11R6: cpio: mkdir failed - No
such file or directory

When investigating it further (installing other packages which are populating 
the filesystem) and trying it again, I see that '/usr' and '/usr/share' are
tagged as 'net shared' also:

| $ rpm -r $D -qs filesystem
| ...
| net shared    /usr
| ...
| net shared    /usr/share


Version-Release number of selected component (if applicable):

rpm-4.2-0.69


How reproducible:

100%
Comment 1 Jeff Johnson 2003-05-15 13:30:21 EDT
Didn't we have this coversation about 40,000 bugs ago? ;-)

The %_netsharedpath macro is known naive, but I still
have not thought of any better mechanism to handle
NFS and rdonly mounts.

Ideas welcomed, possibly on rpm-list as well.
Comment 2 Enrico Scholz 2003-05-15 14:05:34 EDT
Oh, you are right. I have entered so much _netsharedpath reports that I lost the
overview.

But I do not think that the %_netsharedpath macro is naive; indeed, it would be
nice when some fileclasses (info-files, init-scripts, font-directories) are
known to rpm and the %_netsharedpath is honored in the automatic generated
scriptlets, but the current issue is a classical bug.

/usr should not be marked as 'net shared' when only '/usr/share/doc' is in
%_netsharedpath.

*** This bug has been marked as a duplicate of 52725 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:53:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.