Bug 909496 - Add Proxy property
Add Proxy property
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-activex-win (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.0
Assigned To: Marc-Andre Lureau
Desktop QE
: FutureFeature
Depends On:
Blocks: 909469
  Show dependency treegraph
 
Reported: 2013-02-08 17:50 EST by Marc-Andre Lureau
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version: spicex-win-3.2-1
Doc Type: Enhancement
Doc Text:
HTTP proxy support is now available for SPICE clients. The "Proxy" property has been added to the SPICE ActiveX plugin, to configure the client setting via the controller.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:06:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:0921 normal SHIPPED_LIVE spice-activex-win enhancement update 2013-06-10 19:53:18 EDT

  None (edit)
Description Marc-Andre Lureau 2013-02-08 17:50:25 EST
The activex needs a new "Proxy" property to configure the client proxy via controller.

The patch is already in upstream, and it will be release with client update. the bug is just for.. tracking.
Comment 1 Marian Krcmarik 2013-02-12 08:56:27 EST
(In reply to comment #0)
> The activex needs a new "Proxy" property to configure the client proxy via
> controller.
> 
> The patch is already in upstream, and it will be release with client update.
> the bug is just for.. tracking.

Hi,
What is the property name? I assume only string passed from RHEVM without any validation is sent to client controller, correct?
Thanks.
Comment 2 Marc-Andre Lureau 2013-02-12 12:33:12 EST
(In reply to comment #1)
> (In reply to comment #0)
> > The activex needs a new "Proxy" property to configure the client proxy via
> > controller.
> > 
> > The patch is already in upstream, and it will be release with client update.
> > the bug is just for.. tracking.
> 
> Hi,
> What is the property name? I assume only string passed from RHEVM without
> any validation is sent to client controller, correct?
> Thanks.

property name is "Proxy", it's a string with the same content description as environment variable or the virt-viewer configuration file. Also described in spice-protocol:

    The value must be of the form [protocol://]<host>[:port]
    
    The proxy string may be specified with a protocol:// prefix to specify
    alternative proxy protocols.
    
    If no protocol is specified in the proxy string or if the string
    doesn't match a supported one, the proxy will be treated as a HTTP
    proxy.
Comment 3 Uri Lublin 2013-02-13 15:22:10 EST
(In reply to comment #2)
> 
>     The value must be of the form [protocol://]<host>[:port]
>     
>     The proxy string may be specified with a protocol:// prefix to specify
>     alternative proxy protocols.
>     
>     If no protocol is specified in the proxy string or if the string
>     doesn't match a supported one, the proxy will be treated as a HTTP
>     proxy.

If no port is specified port 3128 is used (the default port for squid)
Comment 5 Uri Lublin 2013-02-13 15:26:47 EST
(In reply to comment #1)
> I assume only string passed from RHEVM without
> any validation is sent to client controller, correct?

That's correct.
Comment 8 errata-xmlrpc 2013-06-10 16:06:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0921.html

Note You need to log in before you can comment on or make changes to this bug.