Bug 90951 - cannot delete workflow in certain situations
cannot delete workflow in certain situations
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks: 88926
  Show dependency treegraph
 
Reported: 2003-05-15 14:41 EDT by Richard Li
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 17:12:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Li 2003-05-15 14:41:26 EDT
Description of problem:

Cannot delete a workflow.

Version-Release number of selected component (if applicable):


How reproducible: Probably always.


Steps to Reproduce:
1. Create a workflow.
2. Assign the workflow to some content types/content items (not sure exactly
what here).
3. Try to delete the workflow.
    
Actual results:

*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code: localhost:8100:6b3b92a7:f52bd0fa86 -*-*-*-
-*-*-*- Message: Error executing SQL: 
delete from cw_processes
where process_id=?
Occurred while:
    Deleting information for [com.arsdigita.workflow.simple.Workflow:{id=900}]
(root cause: ORA-02292: integrity constraint (EADEMO.PROCESS_DEF_ID_FK) violated
- child record found
) -*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
accept-encoding: gzip,deflate,compress;q=0.9
accept-language: en-us,en;q=0.5
connection: close
content-length: 322
content-type: application/x-www-form-urlencoded
cookie: ad_user_login=23!1147474814831!5Le86lCcmaB23O9I8Hiv2Q==;
JSESSIONID=E550F0D56CF3C552697ED296149C4904
host: localhost:8100
referer:
http://ea-demo.redhat.com/ccm/content/admin/index.jsp?bbp.497.sel=900&bbp.s=386&bbp.i=20www579c37635u2g6bnh2egmqv5i4tf7n2y2t7el1a4a2vjfywmb8n5o5x0rczfra0q4us050d0q6hfqrh641u3qotzyeova4q1x3963nfawhim56e2frdrue28hfeikd7v0tm12shy2m7dk0a8&bbp.790.d=asc&bbp.3.pane=3&bbp.4.folder=118&bbp.73.ps=20&bbp.341.stack=6&g11n.enc=ISO-8859-1
user-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425
x-forwarded-for: 172.16.52.200
x-forwarded-host: ea-demo.redhat.com
x-forwarded-server: ea-demo.redhat.com

-*-*-*- Section: Cookies -*-*-*-
ad_user_login: 23!1147474814831!5Le86lCcmaB23O9I8Hiv2Q== (expires: -1)
JSESSIONID: E550F0D56CF3C552697ED296149C4904 (expires: -1)

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: Stack trace -*-*-*-
com.arsdigita.persistence.PersistenceException: Error executing SQL: 
delete from cw_processes
where process_id=?
Occurred while:
    Deleting information for [com.arsdigita.workflow.simple.Workflow:{id=900}]
(root cause: java.sql.SQLException: ORA-02292: integrity constraint
(EADEMO.PROCESS_DEF_ID_FK) violated - child record found
)
	at
com.arsdigita.persistence.PersistenceException.newInstance(PersistenceException.java:128)
	at com.arsdigita.persistence.DataStore.fireOperation(DataStore.java(Compiled Code))
	at com.arsdigita.persistence.DataStore.fireEvent(DataStore.java(Compiled Code))
	at com.arsdigita.persistence.DataHandler.doDelete(DataHandler.java(Compiled Code))
	at com.arsdigita.persistence.DataHandler.doDelete(DataHandler.java(Compiled Code))
	at com.arsdigita.persistence.DataHandler.doDelete(DataHandler.java(Compiled Code))
	at com.arsdigita.persistence.DataHandler.doDelete(DataHandler.java(Compiled Code))
	at
com.arsdigita.persistence.GenericDataObject.delete(GenericDataObject.java(Compiled
Code))
	at com.arsdigita.domain.DomainObject.delete(DomainObject.java(Compiled Code))
	at com.arsdigita.workflow.simple.Task.delete(Task.java:1162)
	at com.arsdigita.workflow.simple.Workflow.delete(Workflow.java:213)
	at
com.arsdigita.cms.ui.workflow.WorkflowDeleteForm.process(WorkflowDeleteForm.java:58)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:444)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:418)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:431)
	at com.arsdigita.bebop.Form.respond(Form.java:276)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:241)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:249)
	at com.arsdigita.cms.dispatcher.CMSDispatcher.dispatch(CMSDispatcher.java:257)
	at
com.arsdigita.cms.dispatcher.CMSDispatcher.chainedDispatch(CMSDispatcher.java:337)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:135)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:113)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:128)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:104)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:238)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:683)
	at
org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:431)
	at
org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:355)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardContext.invoke(StandardContext.java(Compiled Code))
	at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java(Compiled Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java(Compiled
Code))
	at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:1125)
	at java.lang.Thread.run(Thread.java:512)
Root cause: 
java.sql.SQLException: ORA-02292: integrity constraint
(EADEMO.PROCESS_DEF_ID_FK) violated - child record found

	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
	at oracle.jdbc.oci8.OCIDBAccess.check_error(OCIDBAccess.java(Compiled Code))
	at oracle.jdbc.oci8.OCIDBAccess.executeFetch(OCIDBAccess.java(Compiled Code))
	at oracle.jdbc.oci8.OCIDBAccess.parseExecuteFetch(OCIDBAccess.java(Compiled Code))
	at
oracle.jdbc.driver.OracleStatement.executeNonQuery(OracleStatement.java(Compiled
Code))
	at
oracle.jdbc.driver.OracleStatement.doExecuteOther(OracleStatement.java(Compiled
Code))
	at
oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java(Compiled
Code))
	at
oracle.jdbc.driver.OraclePreparedStatement.executeUpdate(OraclePreparedStatement.java(Compiled
Code))
	at
oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java(Compiled
Code))
	at com.arsdigita.db.PreparedStatement.doExecute(PreparedStatement.java(Compiled
Code))
	at com.arsdigita.db.PreparedStatement.execute(PreparedStatement.java(Compiled
Code))
	at com.arsdigita.persistence.DataStore.fireOperation(DataStore.java(Compiled Code))
	at com.arsdigita.persistence.DataStore.fireEvent(DataStore.java(Compiled Code))
	at com.arsdigita.persistence.DataHandler.doDelete(DataHandler.java(Compiled Code))
	at com.arsdigita.persistence.DataHandler.doDelete(DataHandler.java(Compiled Code))
	at com.arsdigita.persistence.DataHandler.doDelete(DataHandler.java(Compiled Code))
	at com.arsdigita.persistence.DataHandler.doDelete(DataHandler.java(Compiled Code))
	at
com.arsdigita.persistence.GenericDataObject.delete(GenericDataObject.java(Compiled
Code))
	at com.arsdigita.domain.DomainObject.delete(DomainObject.java(Compiled Code))
	at com.arsdigita.workflow.simple.Task.delete(Task.java:1162)
	at com.arsdigita.workflow.simple.Workflow.delete(Workflow.java:213)
	at
com.arsdigita.cms.ui.workflow.WorkflowDeleteForm.process(WorkflowDeleteForm.java:58)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:444)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:418)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:431)
	at com.arsdigita.bebop.Form.respond(Form.java:276)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:241)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:249)
	at com.arsdigita.cms.dispatcher.CMSDispatcher.dispatch(CMSDispatcher.java:257)
	at
com.arsdigita.cms.dispatcher.CMSDispatcher.chainedDispatch(CMSDispatcher.java:337)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:135)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:113)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:128)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:104)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:238)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:683)
	at
org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:431)
	at
org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:355)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardContext.invoke(StandardContext.java(Compiled Code))
	at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java(Compiled Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java(Compiled
Code))
	at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:1125)
	at java.lang.Thread.run(Thread.java:512)


-*-*-*- Section: Request summary -*-*-*-
Context path: 
Request URI: /ccm/content/admin/index.jsp
Query string: null
Method: POST
Remote user: null

-*-*-*- Section: System properties -*-*-*-
catalina.base: /usr/share/tomcat
catalina.home: /usr/share/tomcat
catalina.useNaming: true
file.encoding: ANSI_X3.4-1968
file.encoding.pkg: sun.io
file.separator: /
invokedviajava: 
java.assistive: ON
java.awt.fonts: 
java.awt.graphicsenv: sun.awt.X11GraphicsEnvironment
java.awt.printerjob: sun.awt.motif.PSPrinterJob
java.class.path:
/opt/IBMJava2-131/lib/tools.jar:/var/www/eademo/dist/WEB-INF/lib/jaas.jar:/var/www/eademo/dist/WEB-INF/lib/jce.jar:/var/www/eademo/dist/WEB-INF/lib/sunjce_provider.jar:/var/www/eademo/dist/WEB-INF/lib/xerces.jar:/var/www/eademo/dist/WEB-INF/lib/xalan.jar:/opt/apps/oracle/product/9.2.0/jdbc/lib/classes12.zip:/usr/share/tomcat/bin/bootstrap.jar:/opt/IBMJava2-131/lib/tools.jar
java.class.version: 46.0
java.compiler: jitc
java.endorsed.dirs: /usr/share/tomcat/bin:/usr/share/tomcat/common/lib
java.ext.dirs: /opt/IBMJava2-131/jre/lib/ext
java.fullversion: J2RE 1.3.1 IBM build cxia32131-20020622 (JIT enabled: jitc)
java.home: /opt/IBMJava2-131/jre
java.io.tmpdir: /tmp
java.library.path:
/opt/IBMJava2-131/jre/bin:/opt/IBMJava2-131/jre/bin/classic:/opt/apps/oracle/product/9.2.0/lib:/usr/lib
java.naming.factory.initial: org.apache.naming.java.javaURLContextFactory
java.naming.factory.url.pkgs: org.apache.naming
java.runtime.name: Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version: 1.3.1
java.specification.name: Java Platform API Specification
java.specification.vendor: Sun Microsystems Inc.
java.specification.version: 1.3
java.vendor: IBM Corporation
java.vendor.url: http://www.ibm.com/
java.vendor.url.bug: 
java.version: 1.3.1
java.vm.info: J2RE 1.3.1 IBM build cxia32131-20020622 (JIT enabled: jitc)
java.vm.name: Classic VM
java.vm.specification.name: Java Virtual Machine Specification
java.vm.specification.vendor: Sun Microsystems Inc.
java.vm.specification.version: 1.0
java.vm.vendor: IBM Corporation
java.vm.version: 1.3.1
javax.xml.parsers.DocumentBuilderFactory:
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
javax.xml.parsers.SAXParserFactory: org.apache.xerces.jaxp.SAXParserFactoryImpl
javax.xml.transform.TransformerFactory:
org.apache.xalan.processor.TransformerFactoryImpl
line.separator: 

org.xml.sax.driver: org.apache.xerces.parsers.SAXParser
os.arch: x86
os.name: Linux
os.version: 2.4.18-27.7.xsmp
path.separator: :
PreferredXSLTTransformer: XALAN
sun.boot.class.path:
/opt/IBMJava2-131/jre/lib/rt.jar:/opt/IBMJava2-131/jre/lib/i18n.jar:/opt/IBMJava2-131/jre/classes
sun.boot.library.path: /opt/IBMJava2-131/jre/bin
sun.io.unicode.encoding: UnicodeLittle
user.dir: /var/www
user.home: /var/www
user.language: en
user.name: servlet
user.timezone: America/New_York
vendor: Apache Software Foundation
vendor-url: http://xml.apache.org/xalan
version: 2.1.0
-*-*-*-*-*- End Error Report -*-*-*-*-*-




Expected results:

Success or a helpful error message.


Additional info:
Comment 1 Jon Orris 2003-06-05 17:12:08 EDT
Fixed

Note You need to log in before you can comment on or make changes to this bug.