Bug 90957 - rpm --rebuilddb doew not work
Summary: rpm --rebuilddb doew not work
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-15 19:20 UTC by Irina Kaliman
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-22 00:13:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Irina Kaliman 2003-05-15 19:20:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02

Description of problem:
The following happened on the systems which I upgraded from 7.2 or 7.3
to 9.0
root@potomac irina]# rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy



Version-Release number of selected component (if applicable):
rpm-4.2-0.69

How reproducible:
Always

Steps to Reproduce:
1.rpm --rebuilddb
2.
3.
    

Actual Results:  error: db4 error(16) from dbenv->remove: Device or resource busy

Expected Results:  get a prompt back

Additional info:

Comment 1 Barry K. Nathan 2003-05-15 20:20:45 UTC
This is a dupe of I-don't-know-how-many other bugs.

It's a harmless error, just ignore it.

Comment 2 Jeff Johnson 2003-05-22 00:13:40 UTC
Yup. Error message is harmless, ignore, as it says
in countless other reports.

Comment 3 Need Real Name 2003-05-22 16:13:02 UTC
HOw could this bug be harmless if I do not get a prompt back???  How do I know 
if rpm databased was rebuilt or not? 

[root@potomac irina]# rpm --rebuilddb
No prompt back! ^C does not work, window is frozen! NO way it is a hramless bug

 Irina Kaliman, System and Network Administrator University of Miami,
  Computer Science department

Comment 4 Barry K. Nathan 2003-05-22 18:36:01 UTC
In that situation, use another terminal (for example, another ssh session or
another X terminal window) to run "top" and see if rpm --rebuilddb is using tons
of CPU time. If it's using lots of CPU it's almost certainly rebuilding the
database. If it's not using CPU time but it's not returning to the prompt
either, then that's a problem.

The "harmless bug" is the db4 error that gets displayed. That error should
appear very near the end of the rebuild, and the prompt should then come back
almost immediately after the error (or at least within several seconds of the
error).

Are you saying that you don't get the prompt back after the db4 error shows up?
That would be a different problem or bug than the "harmless" one Jeff and I are
talking about.


Note You need to log in before you can comment on or make changes to this bug.