Bug 909590 - SELinux is preventing /usr/lib/systemd/systemd-logind from 'setattr' accesses on the blk_file sr0.
SELinux is preventing /usr/lib/systemd/systemd-logind from 'setattr' accesses...
Status: CLOSED DUPLICATE of bug 755535
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-02-09 12:46 EST by s_gollmer
Modified: 2013-02-11 07:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-02-11 07:31:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description s_gollmer 2013-02-09 12:46:33 EST
Description of problem:
SELinux is preventing /usr/lib/systemd/systemd-logind from 'setattr' accesses on the blk_file sr0.

*****  Plugin catchall (100. confidence) suggests  ***************************

If sie denken, dass es systemd-logind standardmässig erlaubt sein sollte, setattr Zugriff auf sr0 blk_file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep systemd-logind /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_logind_t:s0
Target Context                system_u:object_r:virt_content_t:s0
Target Objects                sr0 [ blk_file ]
Source                        systemd-logind
Source Path                   /usr/lib/systemd/systemd-logind
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           systemd-197-1.fc18.1.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-73.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.6.10-4.fc18.x86_64 #1 SMP Tue
                              Dec 11 18:01:27 UTC 2012 x86_64 x86_64
Alert Count                   2
First Seen                    2013-01-31 21:46:08 CET
Last Seen                     2013-01-31 21:48:48 CET
Local ID                      5465b1a8-f2a8-4eda-a40d-1eead0c62e21

Raw Audit Messages
type=AVC msg=audit(1359665328.260:403): avc:  denied  { setattr } for  pid=642 comm="systemd-logind" name="sr0" dev="devtmpfs" ino=8243 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:virt_content_t:s0 tclass=blk_file

type=SYSCALL msg=audit(1359665328.260:403): arch=x86_64 syscall=setxattr success=no exit=EACCES a0=7fa20ea3e4a0 a1=7fa20cca7e17 a2=7fa20ea3ee70 a3=24 items=0 ppid=1 pid=642 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-logind exe=/usr/lib/systemd/systemd-logind subj=system_u:system_r:systemd_logind_t:s0 key=(null)

Hash: systemd-logind,systemd_logind_t,virt_content_t,blk_file,setattr


#============= systemd_logind_t ==============
allow systemd_logind_t virt_content_t:blk_file setattr;

audit2allow -R

#============= systemd_logind_t ==============
allow systemd_logind_t virt_content_t:blk_file setattr;

Additional info:
hashmarkername: setroubleshoot
kernel:         3.6.10-4.fc18.x86_64
type:           libreport

Potential duplicate: bug 755535
Comment 1 Miroslav Grepl 2013-02-11 07:31:30 EST

*** This bug has been marked as a duplicate of bug 755535 ***

Note You need to log in before you can comment on or make changes to this bug.