Bug 909604 - wget: Missing support for SNI (Server Name Indication)
Summary: wget: Missing support for SNI (Server Name Indication)
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: wget
Version: 6.3
Hardware: All
OS: All
medium
medium
Target Milestone: rc
: ---
Assignee: Tomáš Hozza 🤓
QA Contact: Jan Kepler
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks: 1070830
TreeView+ depends on / blocked
 
Reported: 2013-02-09 19:17 UTC by Graham Leggett
Modified: 2014-10-14 04:34 UTC (History)
3 users (show)

(edit)
Cause:
Previously wget was missing support for Server Name Indication (SNI).

Consequence: 
As a result, wget was not able to successfully validate certificated from server that used SNI, even if the certificate was valid.

Fix: 
The SNI support has been ported to the wget distributed in RHEL-6.

Result:
As a result, wget is now able to successfully validate certificate from server that uses SNI, if the certificate is valid.
Clone Of:
(edit)
Last Closed: 2014-10-14 04:34:13 UTC


Attachments (Terms of Use)
Patch for TLS SNI issue (4.30 KB, patch)
2013-02-11 12:41 UTC, Tomáš Hozza 🤓
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1408 normal SHIPPED_LIVE wget bug fix update 2014-10-14 00:54:54 UTC

Description Graham Leggett 2013-02-09 19:17:58 UTC
wget-1.12-1.4.el6 contains no support for SNI (Server Name Indication):

[root@tools01 hooks]# wget --ca-certificate=... --certificate=... https://ci.example.org
--2013-02-09 19:09:23--  https://ci.example.org/
Resolving ci.example.org... 217.72.x.x, 217.72.x.x
Connecting to ci.example.org|217.72.x.x|:443... connected.
ERROR: certificate common name `svn.example.org' doesn't match requested host name `ci.example.org'.

Comment 2 Tomáš Hozza 🤓 2013-02-11 12:40:50 UTC
(In reply to comment #0)
> wget-1.12-1.4.el6 contains no support for SNI (Server Name Indication):
> 
> [root@tools01 hooks]# wget --ca-certificate=... --certificate=...
> https://ci.example.org
> --2013-02-09 19:09:23--  https://ci.example.org/
> Resolving ci.example.org... 217.72.x.x, 217.72.x.x
> Connecting to ci.example.org|217.72.x.x|:443... connected.
> ERROR: certificate common name `svn.example.org' doesn't match requested
> host name `ci.example.org'.

However this is true, your problem might be caused by something else.
wget-1.12-1.4.el6 does NOT support subjectAltName field in certificates
introduced in X.509v3 specification. (Bug #736445)

I will leave this Bug open so it can get fixed in the future.

Comment 3 Tomáš Hozza 🤓 2013-02-11 12:41:53 UTC
Created attachment 696067 [details]
Patch for TLS SNI issue

Comment 4 Graham Leggett 2013-02-11 19:14:26 UTC
This particular bug is an SNI bug, and has nothing to do with subjectAltName. The svn.example.org cert (obviously not it's real name) is a domain validated cert from Thawte, which contains no subjectAltName entries.

Comment 5 Tomáš Hozza 🤓 2013-02-12 07:41:54 UTC
(In reply to comment #4)
> This particular bug is an SNI bug, and has nothing to do with subjectAltName.

I did NOT see the certificate your wget is getting therefore I just stated
there might be also another reason why you are getting this error. 

>The svn.example.org cert (obviously not it's real name) is a
> domain validated cert from Thawte, which contains no subjectAltName entries.

Then this is for sure SNI related bug. Thank you for clarification.

Comment 6 Graham Leggett 2013-02-12 20:17:53 UTC
Just to clarify, the bug was raised after an analysis determined SNI not be working, it wasn't a request for support. Switching wget away and replacing it with curl (which does support SNI) worked around our specific problem for now.

Comment 7 RHEL Product and Program Management 2013-10-13 23:58:06 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 16 errata-xmlrpc 2014-10-14 04:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1408.html


Note You need to log in before you can comment on or make changes to this bug.