Bug 90965 - Start of squid impossible
Summary: Start of squid impossible
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: squid (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-15 20:32 UTC by antonio montagnani
Modified: 2007-04-18 16:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-04 13:04:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description antonio montagnani 2003-05-15 20:32:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

Description of problem:
When I start Squid (for example by Webmin), i get :

Executing /etc/rc.d/init.d/squid start ..

init_cache_dir /var/spool/squid... /etc/rc.d/init.d/squid: line 162:  2871
Abortito                $SQUID -z -F -D 2>/dev/null
Avvio di squid: /etc/rc.d/init.d/squid: line 162:  2872 Abortito               
$SQUID $SQUID_OPTS 2>/dev/null
[FALLITO] 

Same if I start Squid upon booting the PC

Version-Release number of selected component (if applicable):
Squid-2.5.Stable1-2.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.Just start Squid
2.
3.
    

Actual Results:  No start of Squid

Expected Results:  Start-up of Squid

Additional info:

Comment 1 renato ben 2004-02-01 00:00:12 UTC
#  TAG: visible_hostname

#   If you want to present a special hostname in error messages, etc,
#    then define this.  Otherwise, the return value of gethostname()
#    will be used. If you have multiple caches in a cluster and
#    get errors about IP-forwarding you must set them to have 
#    individual
#    names with this setting.
#

#Default:

visible_hostname localhost

Comment 2 danielprakash 2004-03-03 06:08:19 UTC
Bug
####

Root Cause Analysis
@@@@@@@@@@@@@@@@@@@

This is the bug that will occur when the Hostname is not fully 
Qualified domain Name

How to avoid this Bug
@@@@@@@@@@@@@@@@@@@@

  Change the hostname to a FQDN (eg:: foo.dnsserver.ca)

How to verify
@@@@@@@@@@@@@

1. edit /etc/sysconfig/network and change the hostname=localhost     
to foo.dnsserver.ca
2. Restart the machine
3. Run the squid -z or service squid restart or start from webmin





Note You need to log in before you can comment on or make changes to this bug.