Bug 909702 - [abrt]: BUG: Bad page state in process swapper pfn:3ff5e1
[abrt]: BUG: Bad page state in process swapper pfn:3ff5e1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:29a00588a9e13b5e56860a1e7ba...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-10 10:28 EST by Phil Moors
Modified: 2013-02-13 09:24 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 09:24:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Moors 2013-02-10 10:28:03 EST
Additional info:
BUG: Bad page state in process swapper  pfn:3ff5e1
page:ffffea000ffd7840 count:0 mapcount:-2 mapping:          (null) index:0x0
page flags: 0x40000000000000()
Modules linked in:
Pid: 0, comm: swapper Not tainted 3.7.6-201.fc18.x86_64 #1
Call Trace:
 [<ffffffff8162deaa>] bad_page+0xe6/0xfb
 [<ffffffff811383a4>] free_pages_prepare+0x124/0x130
 [<ffffffff8113854d>] __free_pages+0x3d/0x90
 [<ffffffff81d44174>] __free_pages_bootmem+0x98/0xa5
 [<ffffffff81d1d4ae>] __free_pages_memory+0xa3/0xed
 [<ffffffff81d1d64a>] free_low_memory_core_early+0x7b/0x104
 [<ffffffff81d12078>] numa_free_all_bootmem+0x7b/0x86
 [<ffffffff81643109>] ? bad_to_user+0x7b3/0x7b3
 [<ffffffff81d10aca>] mem_init+0x1e/0xed
 [<ffffffff8162b15c>] ? set_nmi_gate+0x48/0x4a
 [<ffffffff81cfba56>] start_kernel+0x1e3/0x3de
 [<ffffffff81cfb672>] ? repair_env_string+0x5e/0x5e
 [<ffffffff81cfb356>] x86_64_start_reservations+0x131/0x135
 [<ffffffff81cfb45a>] x86_64_start_kernel+0x100/0x10f
Comment 1 Dave Jones 2013-02-11 14:32:36 EST
was this after a resume from suspend ?
Comment 2 Phil Moors 2013-02-12 21:17:59 EST
This should be changed to NOTABUG. The problem is a misconfigured BIOS because the people I paid to setup the system never tested it before they delivered it. I should have guessed because one of the four drives I had put in was not even connected to the SATA controller or power. Kept poking around BIOS and found that memory was set to ECC. Go figure. And even though this board has been around a while, I got an old BIOS. Updated that too. The system now appears to be stable. Although I have an overclockable board, I do not overclock.

I noticed a post by you on LKML. A thought occurred to me about why you are seeing more of these problems lately. Since the economic downturn, I had put off purchasing a new system for as long as possible. The old one finally died. So, there may be burgeoning rush to replace failing hardware out in the wild. Add to that, the crack smoking hardware guys at a company the rhymes with DicroDenter and this is what you get.

I will say this: as bad as the MB was configured, anaconda still was able to install F18. However, in this state, any significant IO (copying my home directory data back) would cause a panic.

Sorry for the noise.
Comment 3 Josh Boyer 2013-02-13 09:24:15 EST
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.