Bug 90976 - RPM updates fail on vanilla rh9 system
RPM updates fail on vanilla rh9 system
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-15 19:18 EDT by Anthony Clark
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-22 14:02:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Clark 2003-05-15 19:18:50 EDT
Description of problem:
I installed redhat 9, downloaded the updates from a mirror and tried to rpm -Fvh
them.  Many of the rpm steps failed:

[root@elab-linux2 i386]# rpm -Fvh *.rpm
warning: balsa-2.0.6-2.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing...                ########################################### [100%]
   1:glibc-common           ########################################### [  8%]
   2:glibc                  ########################################### [ 17%]
error: %post(glibc-2.3.2-27.9) scriptlet failed, exit status 121
   3:krb5-libs              ########################################### [ 25%]
   4:openssl                ########################################### [ 33%]
   5:samba-common           ########################################### [ 42%]
   6:samba                  ########################################### [ 50%]
/var/tmp/rpm-tmp.22192: line 3:   783 Segmentation fault      /usr/sbin/useradd
-c "Apache" -u 48 -s /sbin/nologin -r -d /var/www apache 2>/dev/null
   7:httpd                  ########################################### [ 58%]
   8:glibc-devel            ########################################### [ 67%]
/var/tmp/rpm-tmp.63411: line 2:   790 Segmentation fault      /usr/sbin/useradd
-M -o -r -d / -s /sbin/nologin -c "NSCD Daemon" -u 28 nscd >/dev/null 2>&1
   9:nscd                   ########################################### [ 75%]
/var/tmp/rpm-tmp.63411: line 1:   794 Segmentation fault      /usr/sbin/useradd
-u 47 -d /var/spool/mqueue -r -s /sbin/nologin mailnull >/dev/null 2>&1
/var/tmp/rpm-tmp.63411: line 2:   795 Segmentation fault      /usr/sbin/useradd
-u 51 -d /var/spool/mqueue -r -s /sbin/nologin smmsp >/dev/null 2>&1
  10:sendmail               ########################################### [ 83%]
error: %post(sendmail-8.12.8-5.90) scriptlet failed, exit status 139
/var/tmp/rpm-tmp.4459: line 1:   814 Segmentation fault      /usr/sbin/groupadd
-g 77 pcap 2>/dev/null
/var/tmp/rpm-tmp.4459: line 3:   815 Segmentation fault      /usr/sbin/useradd
-u 77 -g 77 -s /sbin/nologin -M -r -d /var/arpwatch pcap 2>/dev/null
  11:tcpdump                ########################################### [ 92%]
  12:xinetd                 ########################################### [100%]
Comment 1 Barry K. Nathan 2003-05-16 04:54:42 EDT
If you were installing the i386 glibc RPM on an i686 or athlon machine, then
this is a likely a dupe of bug 88456.
Comment 2 Anthony Clark 2003-05-16 10:15:12 EDT
While bug 88456 certainly looks like it is a dupe, I am unsure.  My kernel and
glibc are as follows:

glibc 2.3.2 i386
kernel-smp 2.4.20 i686

The kernel and kernel-smp are the only 686 RPM on the system.  I haven't run
into the same reboot problems listed in bug 88456 although I did have to
reinstall a system yesterday because of 88456.

rpm -Fvh *should NOT* attempt to install an i386 over an i686 rpm, but that is
beside the point.

A question:  I don't see any i686 rpms available on either the install CDs or
the mirror ftp sites.  Are there two different distributions of rh9?  Is it OK
to have an i686 kernel with i386 rpms?
Comment 3 Jeff Johnson 2003-05-21 20:23:36 EDT
This sure looks like #88456, as gibc*i386.rpm does not
enable NPTL which is used/needed by rpm-4.2.

Try upgrading to glibc-*.i686.rpm, or, alternatively,
downgrading to rpm-4.1.1 (which doesn't need/use NPTL).

Installing glibc-*.i686.rpm is recommended for Red Hat 9.

Does that fix?
Comment 4 Anthony Clark 2003-05-22 13:52:59 EDT
OK, as per your recommendation:

output from `rpm -qa | grep -E "(glibc|rpm|kernel)" | sort`  (I added the arch
version manually):

glibc-2.3.2-27.9                    i386
glibc-common-2.3.2-27.9             i386
glibc-devel-2.3.2-27.9              i386
glibc-kernheaders-2.4-8.10          i386
kernel-2.4.20-8                     i686
kernel-pcmcia-cs-3.1.31-13          i386
kernel-smp-2.4.20-13.9              i686
kernel-smp-2.4.20-8                 i686
kernel-source-2.4.20-13.9           i386
rpm-4.2-0.69                        i386
rpm-python-4.2-0.69                 i386

# rpm -Uvh glibc-2.3.2-27.9.i686.rpm 
warning: glibc-2.3.2-27.9.i686.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing...                ########################################### [100%]
        package glibc-2.3.2-27.9 is already installed

# rpm --force -Uvh glibc-2.3.2-27.9.i686.rpm             
warning: glibc-2.3.2-27.9.i686.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing...                ########################################### [100%]
   1:glibc                  ########################################### [100%]
Stopping sshd:[  OK  ]
Starting sshd:[  OK  ]

Only change from the first rpm list was as expected:

glibc-2.3.2-27.9                    i386

I rebooted the server and it came up just fine.  I tried updating gnupg as a
quick test:

# rpm -Fvh gnupg-1.2.1-4.i386.rpm lv-4.49.4-9.9.1.i386.rp
m mysql-*.rpm
warning: gnupg-1.2.1-4.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing...                ########################################### [100%]
   1:gnupg                  ########################################### [100%]

So I would tentatively say that this is working.  I'll also have to keep in mind
which rpms are i686 from now on.

Thanks! :-)

A question:  If I have an i686 kernel and glibc, should I be recompiling updates
from the source rpm rather than using the i386 rpms?
Comment 5 Jeff Johnson 2003-05-22 14:02:23 EDT
What's important is NPTL, not i686 vs i386. You need
NPTL support in both glibc/kernel for rpm-4.2 to
be able to "work". For basically legacy reasons NPTL
is deisable in the "i386" versions of kernel/glibc.

There are only a handful of programs where arch specific
compiler flags makes any difference, and even there the
difference is usually at the 10% level *at best*.

So I wouldn't bother recompiling, it's a lot of work for little
gain.

Note You need to log in before you can comment on or make changes to this bug.