Bug 90983 - RFE: Better IRDA configuration user interface
RFE: Better IRDA configuration user interface
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks: 87718
  Show dependency treegraph
 
Reported: 2003-05-15 23:11 EDT by Mitsu Hadeishi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 06:04:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mitsu Hadeishi 2003-05-15 23:11:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I'm putting this bug here although it should really go in a more generalized
"control panel" component.

While trying to get my GSM phone working with GPRS and IRDA, I found the
configuration went quite easily, but only after I had mucked about in the irda
config files by hand.  This bug is an enhancement request, basically to make a
simple little tool to handle IRDA configuration.

At present, irda is in the kernel and it works fine, but unless your laptop
happens to be configured in the way the default settings are set up, it won't
work, and there's no easy way to configure it.  One has to learn about the
configuration files and edit them by hand.

Ideally, the system would do a better job at install time of attempting to
autodetect the irda hardware and what serial port it is on, etc.

However, in lieu of this, at least a control panel that allows the user to set
up the IRDA device to use a specific serial device (i.e., in my case, I had to
set it up to use /dev/ttyS0).

More importantly, however, the irda control panel should have some help text
that explains why the irda port might not be active at all --- i.e., in my case,
there was a conflicting device that overrode the irda port IRQ.  This might be
difficult to autodetect, but it might be nice as a help window (i.e., if
irattach fails to start, it could suggest checking interrupt conflicts, and in
particular it could launch the interrupt browser).

In general, a more unified UI for handling interrupt conflict might be helpful.

Also --- irda is currently not enabled by default --- this control panel could
allow the user to enable or disable irda.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to configure irda
2.
3.
    

Actual Results:  You have to edit text files.

Expected Results:  Requesting a graphical control panel for irda.

Additional info:
Comment 1 Mitsu Hadeishi 2003-05-16 09:26:19 EDT
A couple of other notes on this:

For the Linux newbie, the control panel should prompt them that a likely port
for them to use is /dev/ttyS1 or /dev/ttyS? moore generally.

On laptops, the interrupt conflict is likely caused by a PCMCIA card.  Fixing
this requires editing /etc/pcmcia/config.opts to add an exclusion line for
COM2-/dev/ttyS1 --- at the very least the irda control panel should suggest
doing this, even better, it could edit the /etc/pcmcia/config.opts file
directly.  It might be wise, actually, if /etc/pcmcia/config.opts by default
comes with both irq 3 and 4 excluded, since most laptops these days have IRDA
ports on COM2-/dev/ttyS1 (mine is on ttyS0 only because I switched it to deal
with the irq conflict before I realized I could edit config.opts).  Since PCMCIA
is exclusively a laptop thing, it seems to me this might be a good idea.

Finally, it would be great if the control panel made it clear that the correct
port to use with IR devices is /dev/ircomm0.  For a while I was trying
/dev/ttyS? and this did not work, but then I realized it was ircomm0, and all
was well with my programs.  This would save a lot of time for people trying to
get Linux working on their laptops.

Mitsu
Comment 2 Mitsu Hadeishi 2003-05-16 10:51:48 EDT
Sorry --- I meant to say, it should be made clear to the user that although
they're saying the IR port is on /dev/ttyS1 or whatever, when they want to set
up software to use an IR connection, they should say /dev/ircomm0.  I.e., that's
what I did to get my GPRS modem to work, just put in the right GPRS dialup
number and set /dev/ircomm0 as the port of a generic modem.

One thing though: I was using the generic modem that was autodetected when I had
my phone connected via a normal serial cable.  If I never had a generic modem
autodetected, I wonder how easy it would have been for me to get the setup
working?  This I suppose is another issue --- can the system autodetect a modem
attached to the IR port?  Or if not, it should be made easy to install a generic
modem for IR port connectivity in the internet configuration wizard.

Another thing: at the moment the irda is configured by default to use /dev/ttyS2
(COM3), but I think the vast majority of laptops today have it set up as
/dev/ttyS1 (COM2).  I think for "out of the box" functionality for laptops, it
would be more logical to have the default configuration be pcmcia excluding irq
3 and 4, and irda setup on /dev/ttyS1.  If this were the setup most users
wouldn't have to do anything other than turn on the irda service.

Note You need to log in before you can comment on or make changes to this bug.