Bug 90993 - USB hotplug when resuming after suspend reboots laptop with 2.4.20-13.9
USB hotplug when resuming after suspend reboots laptop with 2.4.20-13.9
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-16 03:48 EDT by Didier
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-03 04:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsmod (1.82 KB, text/plain)
2003-05-16 03:52 EDT, Didier
no flags Details
lspci (11.12 KB, text/plain)
2003-05-16 15:13 EDT, Didier
no flags Details
suspend/resume/reboot with 2.4.20-13.9 (3.49 KB, text/plain)
2003-05-16 15:15 EDT, Didier
no flags Details
suspend/resume with 2.4.20-9 (5.49 KB, text/plain)
2003-05-16 15:16 EDT, Didier
no flags Details

  None (edit)
Description Didier 2003-05-16 03:48:38 EDT
Description of problem:

After having resumed my laptop after a suspend, the system reboots when
inserting an USB mouse or an USB hub (with USB mouse attached).

Version-Release number of selected component (if applicable):

kernel-2.4.20-13.9


How reproducible:

I would say, at least 60-70% of the time (could be higher, 2.4.20-13.9 not
running long enough for my figures to be statistically relevant).


Steps to Reproduce:
1. suspend laptop, remove USB device (mouse or hub)
2. resume laptop, make sure system works OK by entering some keysotrokes
3. attach USB device


Actual results:

System warm reboots


Expected results:

System should continue to run


Additional info:

- IBM ThinkPad A30p, running RHL 7.3, 8.0 and 9.0 with 2.4.20-9 (almost) flawlessly
- Occurs when resuming under X (4.3.0-2), didn't try yet with console only
- with both of my USB ports
- since 2.4.20-13.9 (pity, because it fixes bug #86180, BAP with wireless
orinoco for me)
- no messages in /var/log/messages


I don't have the slightest idea how to trace this. Would it prove beneficial for
 extra bug information if I recompiled 2.4.20-13.9 from src.rpm without the USB
patch (bug #89743) ? How ?
Is there a kernel-debuginfo ?
Comment 1 Didier 2003-05-16 03:52:18 EDT
Created attachment 91716 [details]
lsmod
Comment 2 Didier 2003-05-16 04:53:07 EDT
As for the moment I'm only experiencing this bug when resuming in X, I've
mentioned this bug in bug #90997 (XFree86 : "Keyboard lost after upgrading to
kernel 2.4.20-13.9").

Please note that I turned xscreensaver off, as to exclude any correlation with
possible OpenGL bugs (xscreensaver kicks in when resuming from a suspend).


As this crash only occurs after hotplugging an USB device after resume (before
hotplugging, I can enter keystrokes), I do not initially suspect apmd.


Comment 3 Didier 2003-05-16 15:12:59 EDT
Putting right foot in mouth (I'm rapidly running out of feet) :


I just experienced the reboot without plugging in an USB mouse, about one minute
after resuming from suspend, so the erroneous behaviour has probably nothing to
do with USB hotplugging.


In attachment :

1. output from lspci -tv and lspci -vv

2. /var/log/messages output from :

- kernel 2.4.20-13.9 suspend (17:34), resume (20:10) and crash/reboot (20:12)

- kernel 2.4.20-9 suspend (20:24:06) and resume (20:24:30)



Notes about cruft /var/log/messages :
* floppy messages : this laptop has a removable floppy drive, which is absent
* /dev/sda1 refers to an absent IEEE-1394 harddisk based partition
* hermes is the driver for a mini-PCI based Orinoco/PrismII wireless card (this
bug #86180 is - oh irony - fixed in 2.4.20-13.9.
Comment 4 Didier 2003-05-16 15:13:53 EDT
Created attachment 91740 [details]
lspci
Comment 5 Didier 2003-05-16 15:15:51 EDT
Created attachment 91741 [details]
suspend/resume/reboot with 2.4.20-13.9
Comment 6 Didier 2003-05-16 15:16:49 EDT
Created attachment 91742 [details]
suspend/resume with 2.4.20-9
Comment 7 Didier 2003-05-19 03:57:47 EDT
As I'm experiencing some strange anomalies wrt suspends/reboots with 2.4.20-9
now too, I'm having my machine serviced.
Comment 8 Didier 2003-05-29 15:28:34 EDT
Huh ? Seems like someone closed this bug without me receiving an e-mail alert ?

However, after my notebook system board got replaced last week, I performed
several suspend/resume cycles, with the problem reoccuring.

I suppose the problem was related to hardware degradation.
CLOSED -> NOTABUG ?
Comment 9 Pete Zaitcev 2003-06-02 21:34:56 EDT
Didier, the activity log shows that you closed it yourself (by mistake?).
Reopening...
Comment 10 Didier 2003-06-03 04:44:32 EDT
Dear Pete,

Yes, I noticed that too.
Although I'm quite positive I did not touch the bug status, I just noticed I
wrote  in comment #8, "with the problem reoccuring", which should actually read
"with*out* the problem reoccuring. *blush*

My sincere apologies for wasting your valuable time.

Changing to resolved, NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.