Bug 90995 - not show everything
not show everything
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-16 04:46 EDT by Sebastian Boinski
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-16 09:11:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Boinski 2003-05-16 04:46:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)

Description of problem:
I wrote aplication that from main proces fork 5 times. When I tested it on RH 
8.0 ps didn't show one process. According to data in /proc process existed and 
was running (on other platform I didn't have such problems) . When I tested a 
job made by this process everything was OK. I suggestet that there is a bug in 
ps.

Version-Release number of selected component (if applicable):
procps

How reproducible:
Always

Steps to Reproduce:
1. I run my soft in any situation that they gets different PID
2. Everytime there was this same problem
3.
    

Additional info:
Comment 1 Alexander Larsson 2003-05-16 09:11:22 EDT
The ps in RH8 (and upstream ps too, in later versions) doesn't show subthreads
by default. To get them you need to pass -m to ps. Due to the way threads are
handled in LinuxThreads there is no really 100% correct way to detect what
processes are threads, so it uses a hack. When a child process has identical
name and vmsize as its parent its assumed to be a thread.

This is fixed in RHL9 with the introduction of NPTL.

Note You need to log in before you can comment on or make changes to this bug.