Bug 91001 - 2.4.20-13.9 update prevents ZIP drive from working
Summary: 2.4.20-13.9 update prevents ZIP drive from working
Status: CLOSED DUPLICATE of bug 91381
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-16 09:32 UTC by Tim Waugh
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:53:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2003-05-16 09:32:24 UTC
Description of problem:
After booting into 2.4.20-13.9 (i686) my parallel-port connected ZIP drive no
longer works.  When I boot back to 2.4.20-9 (i686) it works again.

This model uses the imm driver; I have seen an identical failure report for a
modem that uses the ppa driver.

Version-Release number of selected component (if applicable):
2.4.20-13.9

How reproducible:
100%

Steps to Reproduce:
1. Boot to 2.4.20-13.9
2. Load ZIP drive driver module
    
Actual results:
imm: Version 2.05 (for Linux 2.4.0)
imm: Found device at ID 6, Attempting to use EPP 32 bit
imm: Communication established at 0x378 with ID 6 using EPP 32 bit
scsi3 : Iomega VPI2 (imm) interface
  Vendor: IOMEGA    Model: ZIP 250           Rev: L.58
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi removable disk sdb at scsi3, channel 0, id 6, lun 0
scsi: device set offline - not ready or command retry failed after bus reset:
host 3 channel 0 id 6 lun 0
SCSI device sdb: 196608 512-byte hdwr sectors (101 MB)
sdb: Write Protect is off
 sdb: I/O error: dev 08:10, sector 0
 I/O error: dev 08:10, sector 0
 unable to read partition table

Expected results:
imm: Version 2.05 (for Linux 2.4.0)
imm: Found device at ID 6, Attempting to use EPP 32 bit
imm: Communication established at 0x378 with ID 6 using EPP 32 bit
scsi3 : Iomega VPI2 (imm) interface
  Vendor: IOMEGA    Model: ZIP 250           Rev: L.58
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi removable disk sdb at scsi3, channel 0, id 6, lun 0
SCSI device sdb: 196608 512-byte hdwr sectors (101 MB)
sdb: Write Protect is off
 sdb: sdb4

Comment 1 Tim Waugh 2003-05-21 08:27:13 UTC
Tried 13.9.1 - no change.

Comment 3 Alan Cox 2003-06-05 15:52:31 UTC
The newer Scsi code does further checks on the drive being ready etc. It looks
like this is the problem. Unfortunately it'll take someone with the hardware to
figure out why the sd driver decided the disk was still offline


Comment 4 Alan Cox 2003-06-08 13:41:29 UTC

*** This bug has been marked as a duplicate of 91381 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:53:03 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.