Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 910183 - Search in Document List does not show when on page 2+ of Document List
Search in Document List does not show when on page 2+ of Document List
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Retired
Component: Component-UI (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.3
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-11 18:37 EST by Hedda Peters
Modified: 2013-11-26 22:36 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.3-SNAPSHOT (20130410-1246)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:23:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2013-02-11 18:37:06 EST
Description of problem:
When searching for a specific document name in the document list view, the search result does not immediately show if the user was on page 2 (or higher) in the document list when running the search. 

Version-Release number of selected component (if applicable):
Zanata version 2.1.4 (20130208-0211).

How reproducible:
always

Steps to Reproduce:
1. Open any document list for a project with more than 1 page of documents
2. Go to page 2 (or higher) of the document list
3. Search for a specific document name
  
Actual results:
The document list remains on page 2. Since there are not 2 pages worth of search results, that document list now looks empty. The actualy search result only shows when moving back to page 1.

Expected results:
The document list should show the search result immediately, regardless on which page the user was when running the search
Comment 1 Alex Eng 2013-04-08 23:09:12 EDT
This issue should be fixed with the refactoring of document list in 2.3 Release.
Need to verify from QA
Comment 2 Ding-Yi Chen 2013-04-10 01:37:27 EDT
VERIFIED with Zanata version 2.3-SNAPSHOT (20130410-1246)
Comment 3 Sean Flanigan 2013-11-26 22:13:44 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 4 Sean Flanigan 2013-11-26 22:15:40 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 5 Sean Flanigan 2013-11-26 22:19:13 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 6 Sean Flanigan 2013-11-26 22:23:33 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 7 Sean Flanigan 2013-11-26 22:33:54 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 8 Sean Flanigan 2013-11-26 22:36:08 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.

Note You need to log in before you can comment on or make changes to this bug.