Bug 910215 - [RFE] Allow dash ('-') in Logical Network name in RHEV
Summary: [RFE] Allow dash ('-') in Logical Network name in RHEV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Michal Skrivanek
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-12 02:37 UTC by Jaison Raju
Modified: 2018-12-03 18:20 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:29:17 UTC
oVirt Team: Network
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 41019 master MERGED Core, UI: Allow '-' in network name Never
Red Hat Knowledge Base (Solution) 502553 None None None Never

Comment 5 Andrew Cathrow 2013-10-10 15:18:27 UTC
Do the description fields we've got in 3.3 help?

Comment 7 Itamar Heim 2013-12-01 22:03:44 UTC
the problem is that if we go this way, we'd have to use an entirely different ID for the bridge name. I think having UUID's as bridge names won't be favored more...
any chance rhel will support this in bridge names?

Comment 12 Dan Kenigsberg 2014-01-15 12:34:08 UTC
I've updated the upstream feature page for this. Do the remedies suggested under http://www.ovirt.org/Features/Unrestricted_Network_Names#Debuggability_Drawback make sense to GSS/PM?

Current suggestions are
1. An ovirt-engine-shell script to map a brXXXXXXXXXXXXX name into the visible name of its owning network.
2. Make it possible to look a network up based on its vdsm_name (brXXXXXXXXXXXXX) in the network tab and in via the search box
3. Expose visible_name to the host when setting or changing a network via setupNetwork. visible_name would be persisted on the local host, and would be available for inspection by debuggers.

Comment 15 GenadiC 2014-03-19 11:36:52 UTC
It should be verified for external networks as well.
So if I import network with special characters from Neutron Provider to RHEV, the import should succeed

Comment 26 Dan Kenigsberg 2015-03-23 17:11:03 UTC
Vdsm allows any character in bridge names except for space, colon, and tab. However, other platform scripts may assign special meaning for special characters.

For example, vdsm uses a specially-crafted bridge name ";vdsmdummy;" (notice the semicolons) internally. This was done to avoid collision with Engine-created names. But more painfully, it caused puppet to scream, as it did not handle the semicolon properly. Similarly, I suspect that many scripts in the sysadmin world would explode if we allowed a quotation mark or "@" or non-printable characters.

Specifically, the dash symbol seems fine to me, and can be declared as valid in GUI (actually, we use a network name with a dash in vdsm unit test).

But I don't think we should spend our time validating each and every character to be added to the valid set.

Comment 27 Yaniv Lavi 2015-03-31 09:18:53 UTC
Per Dan's comment #26, is there any change needed? because the limitation here is very specific and fits with the platform support.

Comment 28 Martin Tessun 2015-03-31 13:00:47 UTC
(In reply to Yaniv Dary from comment #27)
> Per Dan's comment #26, is there any change needed? because the limitation
> here is very specific and fits with the platform support.

Well, at least the Dashes "-" should be supported as stated in C #19. Ideally everything that can be set with NetworkManager / RHEL networking for interface names as well, so that the naming is consistent in RHEV-M and on the Hypervisor to easily identify the corresponding network in RHEV.

Cheers,
Martin

Comment 29 Yaniv Lavi 2015-04-01 07:02:43 UTC
Is the engine blocking the vdsm and RHEL supported names? can you create a network with a dash?

Comment 30 Lior Vernia 2015-04-01 07:20:29 UTC
The engine allows a-z, A-Z, 0-9 and '_'. So dash is considered invalid. This can be fixed trivially, if this is okay on the host side.

Comment 38 Max Kovgan 2015-06-28 14:12:47 UTC
ovirt-3.6.0-3 release

Comment 39 Michael Burman 2015-07-01 08:05:09 UTC
Verified on - 3.6.0-0.0.master.20150627185750.git6f063c1.el6

Comment 42 errata-xmlrpc 2016-03-09 20:29:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.