Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 910216 - Statistics API returns word level statistics when only message level statistics are requested
Statistics API returns word level statistics when only message level statisti...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Retired
Component: Component-API (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.2
Assigned To: David Mason
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-11 21:38 EST by David Mason
Modified: 2013-11-26 22:36 EST (History)
0 users

See Also:
Fixed In Version: 2.2-SNAPSHOT (20130221-0034)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:23:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2013-02-11 21:38:50 EST
Description of problem:
When getting stats using the REST API (e.g. using maven plugin), default setting is not to include word level statistics, but the API always returns word statistics.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set up maven client, zanata.xml and zanata.ini for a project
2.Run 'mvn zanata:stats'

  
Actual results:
Message and Word stats are shown

Expected results:
Only Message stats are shown

Additional info:
Caused by changes in https://github.com/zanata/zanata/commit/aed6918571a4f6f9bce2af87b104c613f6784671
Comment 1 David Mason 2013-02-11 21:40:51 EST
Fixed in 2.2-SNAPSHOT

See: https://github.com/zanata/zanata/commit/4ed20fea576d4dcd959e9a9b29d179442d5ffb0c
Comment 2 Ding-Yi Chen 2013-02-20 23:20:19 EST
VERIFIED with Zanata version 2.2-SNAPSHOT (20130221-0034)
Maven client 2.0.2-SNAPSHOT
Comment 3 Sean Flanigan 2013-11-26 22:14:01 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 4 Sean Flanigan 2013-11-26 22:15:53 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 5 Sean Flanigan 2013-11-26 22:19:29 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 6 Sean Flanigan 2013-11-26 22:23:49 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 7 Sean Flanigan 2013-11-26 22:34:16 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 8 Sean Flanigan 2013-11-26 22:36:25 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.

Note You need to log in before you can comment on or make changes to this bug.