Bug 91022 - quotacheck -vn Segmentation fault while checking
quotacheck -vn Segmentation fault while checking
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Brock Organ
:
Depends On: 53591
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-16 11:57 EDT by Petri T. Koistinen
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 13:12:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
How error shows to user (5.45 KB, text/plain)
2003-05-16 12:00 EDT, Petri T. Koistinen
no flags Details
/var/aquota.group (9.00 KB, application/octet-stream)
2003-05-16 12:06 EDT, Petri T. Koistinen
no flags Details
/var/aquota.user (115.00 KB, application/octet-stream)
2003-05-16 12:13 EDT, Petri T. Koistinen
no flags Details
strace quotacheck -vn /dev/cciss/c0d0p6 2>strace.txt (89.19 KB, text/plain)
2003-05-16 12:17 EDT, Petri T. Koistinen
no flags Details
core dump (656.00 KB, application/octet-stream)
2003-05-16 12:24 EDT, Petri T. Koistinen
no flags Details

  None (edit)
Description Petri T. Koistinen 2003-05-16 11:57:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
quotacheck -vn /dev/cciss/c0d0p6 segfaults when lots of errors are found.


Version-Release number of selected component (if applicable):
quota-3.03-1

How reproducible:
Always

Steps to Reproduce:
1. quotacheck -vn /dev/cciss/c0d0p6

Actual Results:  See attached files.

Additional info:
Comment 1 Petri T. Koistinen 2003-05-16 12:00:06 EDT
Created attachment 91726 [details]
How error shows to user
Comment 2 Petri T. Koistinen 2003-05-16 12:06:51 EDT
Created attachment 91728 [details]
/var/aquota.group
Comment 3 Petri T. Koistinen 2003-05-16 12:13:11 EDT
Created attachment 91731 [details]
/var/aquota.user
Comment 4 Petri T. Koistinen 2003-05-16 12:17:09 EDT
Created attachment 91732 [details]
strace quotacheck -vn /dev/cciss/c0d0p6 2>strace.txt
Comment 5 Petri T. Koistinen 2003-05-16 12:24:08 EDT
Created attachment 91733 [details]
core dump
Comment 6 Binand Sethumadhavan 2003-07-22 07:25:22 EDT
This seems to be the same error as I get (production system, cannot run 
quotacheck):

[root@necropolis root]# repquota /home
*** Report for user quotas on device /dev/ida/c0d0p9
Block grace time: 7days; Inode grace time: 7days
                        Block limits                File limits
User            used    soft    hard  grace    used  soft  hard  grace
----------------------------------------------------------------------
Segmentation fault

I have about 350 users (all in one group) with quota enabled. Samba runs and 
is the Primary DC of a domain. Redhat 7.3 fully up2dated.

Please let me know if any additional details are required (strace/ltrace, 
other config parameters etc).
Comment 7 Petri T. Koistinen 2003-07-22 14:18:11 EDT
Just use force, Jedi.
Comment 8 Doug Sibley 2003-09-17 08:22:40 EDT
By any chance did you upgrade to the new openssl packages today (or new
initscripts or procfs)? I am getting segfault on "quota" and nothing for the
other commands (blank output).

Note You need to log in before you can comment on or make changes to this bug.