Bug 9103 - Gdb cannot see threads in core files
Gdb cannot see threads in core files
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: gdb (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-03 14:26 EST by Michael Ubell
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-07 17:12:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Ubell 2000-02-03 14:26:51 EST
Using Linux kernel threads, if the program dumps core
gdb does not see multiple threads.  It only sees one thread
(which never seems to be the one that faulted).
This could be a kernel problem with the way the core
file is generated.
Comment 1 Michael Ubell 2000-02-03 14:28:59 EST
Oh yes: I'm using version 4.17.0.11 of GDB and the Linux 6.0
release from the RedHat CD.
Comment 2 Jeff Johnson 2000-02-07 17:12:59 EST
You might try rebuilding the latest gdb-4.18-9 from Raw Hide on your
6.1 system:
	rpm --rebuild gdb-4.18-9.src.rpm
	rpm -U /usr/src/redhat/RPMS/*/gdb-4.18-9.*.rpm
However, I suspect that there are still problems with thread support there.
These issues will (probably) not be resolved until the next major release of
gdb.

Note You need to log in before you can comment on or make changes to this bug.