Bug 910442 - doubel quoted libra_server breaks existing JBDS/JBoss Tools users
Summary: doubel quoted libra_server breaks existing JBDS/JBoss Tools users
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: oc
Version: 2.x
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Clayton Coleman
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-12 16:23 UTC by Andre Dietisheim
Modified: 2015-05-15 02:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-13 23:09:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker JBIDE-13522 Major Closed Cannot create a connection to OpenShift after fresh install of rhc-tooling 2015-06-25 06:24:30 UTC

Description Andre Dietisheim 2013-02-12 16:23:07 UTC
Description of problem:
latest rhc is creating express.conf (for new users) with double quoted values. Especially libra_server is breaking existing (Eclipse) JBoss Tools use, since it cannot handle this change in the configuration format (it can only handle either single quoted or non-quoted values).

Version-Release number of selected component (if applicable):
1.5.1(?)

How reproducible:
always

Steps to Reproduce:
1. ASSERT: have a system without any express.conf files
2. EXEC: eventually install rhc to it, run initial setup and get /etc/openshift/express.conf created 
3. ASSERT: check libra_server= and make sure it contains "openshift.redhat.com" with double quotes
4. install JBoss Developer Studio and launch "File->New->Other->OpenShift Application
5. Fill in your credentials and try to connect to OpenShift

Actual results:
It will always tell you that your credentials are invalid

Expected results:
It should be able to connect to OpenShift using your valid credentials

Additional info:
JBoss Tools (JBDS) is reading express.conf but cannot handle the double quoted host name. It'll therefore try to connect to the double quoted host name which of course fails. JBT will then report invalid credentials whereas it should tell you that it failed to connect to the libra_server.

Comment 1 Clayton Coleman 2013-02-13 03:13:29 UTC
Reverting to no quotes.  express.conf is now considered a public API to openshift and will not be changed with backwards compatibility.  It may be moved in the future, at which point express.conf will no longer be updated.

Comment 2 Clayton Coleman 2013-02-13 03:14:58 UTC
https://github.com/openshift/rhc/pull/301

Comment 3 Clayton Coleman 2013-02-13 03:15:25 UTC
This will be pushed to stage as a hotfix tomorrow.

Comment 4 Chandrika Gole 2013-02-13 06:46:29 UTC
verified this using rhc-1.4.8 on staging

Steps to reproduce -

1. On a system w/o express.conf installed rhc-1.4.8
2. Run rhc setup
3. Check the ~/openshift/express.conf.
========================================================================
# The OpenShift server to connect to
libra_server=openshift.redhat.com

# Your OpenShift login name
default_rhlogin=cgole@redhat.com

# The default timeout for network operations
#timeout=<integer>

# If true, certificate errors will be ignored.
# WARNING: This may allow others to eavesdrop on your communication with OpenShift.
#insecure=<boolean>

# The SSL protocol version to use when connecting to this server
#ssl_version=<string>

# A client certificate file for use with your server
#ssl_client_cert_file=<path_to_file>

# A file containing CA one or more certificates
#ssl_ca_file=<path_to_file>
========================================================================

4. Open Jboss studio
5. Go to File/New/OpenShiftApplication and create new app

Credentials worked. Tried it against stg.openshift.com and openshift.com

Comment 5 openshift-github-bot 2013-02-26 00:07:00 UTC
Commit pushed to master at https://github.com/openshift/rhc

https://github.com/openshift/rhc/commit/cd5b716d8b2e7c5ef3b69782d75aaea865c05a5f
Bug 910442 - Write config file without quotes

Comment 6 JBoss JIRA Server 2013-04-12 10:52:08 UTC
Stefan Bunciak <sbunciak@redhat.com> updated the status of jira JBIDE-13522 to Closed

Comment 7 JBoss JIRA Server 2013-04-12 10:52:08 UTC
Stefan Bunciak <sbunciak@redhat.com> made a comment on jira JBIDE-13522

Verified in JBoss Developer Studio

Version: 7.0.0.Alpha2
Build id: Alpha2-v20130407-2320-B135
Build date: 20130407-2320


Note You need to log in before you can comment on or make changes to this bug.