Bug 910481 - (bomber) Review Request: bomber - Arcade bombing game
Review Request: bomber - Arcade bombing game
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: nucleo
Fedora Extras Quality Assurance
:
Depends On: libkdegames
Blocks: kde-reviews kde-4.10
  Show dependency treegraph
 
Reported: 2013-02-12 13:06 EST by Rex Dieter
Modified: 2013-02-18 09:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 09:06:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
alekcejk: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2013-02-12 13:06:32 EST
Spec URL: http://rdieter.fedorapeople.org/rpms/kdegames/bomber.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/kdegames/bomber-4.10.0-1.fc18.src.rpm
Description: A single player arcade game
Fedora Account System Username: rdieter
Comment 1 nucleo 2013-02-13 12:55:11 EST
This description from bomber.desktop will be more informative than "A single player arcade game"

Summary: Arcade Bombing Game

All sources in src are under "GNU Library General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version". Documentation in doc licensed with "GNU Free Documentation License".
Documentation say that "This program is licensed under the terms of the GNU General Public License." but actual sources license is LGPLv2+.

So license tag should be

License: LGPLv2+ and GFDL

There are no GPLv2+ files, so license included in %doc should be COPYING.LIB and COPYING.DOC. Also README.themes can be added in %doc.

rpmlint say "bomber.spec:66: W: macro-in-comment %{name}" so this line can be removed
#{_kde4_configdir}/%{name}*
Comment 2 Rex Dieter 2013-02-13 13:41:33 EST
Spec URL: http://rdieter.fedorapeople.org/rpms/kdegames/bomber.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/kdegames/bomber-4.10.0-2.fc18.src.rpm

%changelog
* Wed Feb 13 2013 Rex Dieter <rdieter@fedoraproject.org> 4.10.0-2
- update summary/description
- fix License
Comment 3 Rex Dieter 2013-02-13 14:02:40 EST
Spec URL: http://rdieter.fedorapeople.org/rpms/kdegames/bomber.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/kdegames/bomber-4.10.0-3.fc18.src.rpm

%changelog
* Wed Feb 13 2013 Rex Dieter <rdieter@fedoraproject.org> 4.10.0-3
- update %%description
Comment 4 nucleo 2013-02-13 14:40:51 EST
.spec still 4.10.0-1, I checked spec from 4.10.0-3.fc18.src.rpm

MUST Items:
+ rpmlint output
  $ rpmlint bomber-4.10.0-1.fc18.i686.rpm bomber-debuginfo-4.10.0-1.fc18.i686.rpm bomber-4.10.0-3.fc18.src.rpm bomber.spec 
    bomber.i686: W: no-manual-page-for-binary bomber
    3 packages and 1 specfiles checked; 0 errors, 1 warnings.
+ named and versioned according to the Package Naming Guidelines.
  Package name match the upstream tarball name bomber-4.10.0.tar.xz
+ spec file name bomber.spec matches base package name
+ complies with all the legal guidelines:
  + License: LGPLv2+ and GFDL, matches actual license (added notices for parts under different licenses)
  + No known patent problems
  + No emulator, no firmware, no binary-only or prebuilt components
+ COPYING.LIB (GNU LIBRARY GENERAL PUBLIC LICENSE Version 2), COPYING.DOC (GNU Free Documentation License Version 1.2) packaged as %doc
+ source matches upstream:
  MD5: 7a55f6c2e80a75addf756e3850e1e160  bomber-4.10.0.tar.xz
  SHA1: d9aaba9642c7e18977aa02805e9a418d2d806c28  bomber-4.10.0.tar.xz
  SHA256: dd25b513a447968246a3fd541a0c6f4c84048f9d6e48c87148ebb2afa124dc4b  bomber-4.10.0.tar.xz
+ builds on at least one arch
  build from mock is in F18 kde-unstable repo
+ no known non-working arches, so no ExcludeArch needed
+ no missing BuildRequires (builds in mock)
+ locales are handled properly by using %find_lang %{name} --with-kde macro
+ ldconfig call not needed (no shared libraries)
+ no duplicated system libraries
+ package not relocatable (no Prefix tag)
+ directory ownership correct (doesn't own directories owned by another package, owns all package-specific directories %{_kde4_appsdir}/%{name}/)
+ no duplicate files in %files
+ permissions correct, %defattr(-,root,root,-) not needed now, executables have executable permissions
+ macros used where possible (%{name}, %{version}, %{buildroot}, %{_target_platform}, %{cmake_kde4}, %{_kde4_datadir}, %{_kde4_bindir}, %{_kde4_configdir}, %{_kde4_iconsdir},%{_kde4_appsdir} )
+ non-code content: only permitted content, game themes under license that matches the code
+ no large documentation files, so no -doc package needed
+ no %doc files required at runtime
+ no header files, no -devel package needed
+ no static libraries, so no -static package needed
+ no devel symlinks which would need to be in a -devel subpackage
+ devel packages must require the base package (no -devel package)
+ no .la files
+ bomber.desktop file for the GUI app bomber present
+ desktop-file-validate is used in %check and the bomber.desktop file passes validation
+ all filenames are valid UTF-8
+ other packaging guidelines:
  + complies with the Filesystem Hierarchy Standard (all files in %{_kde4_datadir}, %{_kde4_bindir}, %{_kde4_configdir}, %{_kde4_iconsdir},%{_kde4_appsdir})
  + proper changelog, tags, BuildRequires, Summary, Description (got from bomber's documentation)
  + no non-UTF-8 characters
  + all relevant documentation included as %doc (COPYING.LIB, COPYING.DOC)
  + RPM_OPT_FLAGS are used in %{cmake_kde4} macro
  + debuginfo package is valid (contains stripped symbols from ELF binary and source code related to it)
  + no rpaths (no check-rpaths error)
  + no configuration files, so %config guideline doesn't apply
  + no init scripts, so init script guideline doesn't apply
  + timestamps are preserved
  + %{?_smp_mflags} used
  + not a web application, so web application guideline doesn't apply
  + no conflicts (kdegames-4.10.0 is metapackage now which not includes apps)

SHOULD Items:
+ license already included upstream
+ no translations for description and summary provided by upstream
+ package builds in mock (built for kde-unstable)
- successfully tested the package functionality (no testing yet)
+ scriptlets are sane (updating icon chache in %post, %postun, %posttrans)
+ subpackages other than devel should require the base package using a fully versioned dependency (no subpackages)
+ no .pc files, so "placement of .pc files" is irrelevant
+ no file dependencies
- package should contain man pages for binaries/scripts

So, package APPROVED.
Comment 5 Rex Dieter 2013-02-14 08:19:37 EST
New Package SCM Request
=======================
Package Name: bomber
Short Description: Arcade bombing game
Owners: than rdieter jreznik kkofler ltinkl rnovacek
Branches: f17 f18
InitialCC:
Comment 6 Jon Ciesla 2013-02-14 10:02:54 EST
Git done (by process-git-requests).
Comment 7 Rex Dieter 2013-02-18 09:06:09 EST
imported

Note You need to log in before you can comment on or make changes to this bug.