Bug 91053 - usb-uhci not being loaded
usb-uhci not being loaded
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-16 16:44 EDT by Ken Bass
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-19 15:33:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Bass 2003-05-16 16:44:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Performed an upgrade install from Redhat 8 to Redhat 9.

During boot process, got message that when loading the 
printer, /dev/usb/lp0 does not exist. Running usbview did not
show the device.

lspci (USB):
00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801DB USB EHCI Controller (rev 02)

usbview - only showed EHCI. No UHCI devices were present.

Appears that usb-uhci.o driver is not being loaded!

Tried running kudzu - that didn't help.
Tried running redhat-config-printer - removed and readded device - wasn't detected.

Loading usb-uhci.o by hand and printer is now seen. Seems install/upgrade
process is not handling this printer correctly.

All this was working under Redhat 8.0.

/etc/modules.conf:
alias parport_lowlevel parport_pc
alias scsi_hostadapter aic7xxx
alias eth0 bcm4400
alias usb-controller usb-uhci
alias sound-slot-0 audigy
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias ieee1394-controller ohci1394
alias char-major-81 bttv
alias usb-controller1 ehci-hcd
options st buffer_kbs=1408
alias usb-controller ehci-hcd
alias char-major-195 nvidia

Good the upgrade process have been responsible for adding
2 entries above for 'alias usb-controller'. One says ehci-hcd, 
the other says usb-uhci

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade from 8.0 to 9.0
2. Driver usb-uhci not being loaded (/etc/modules.conf incorrect?)

    

Additional info:
Comment 1 Bill Nottingham 2003-05-19 15:33:32 EDT
This is an installer issue on upgrades. It's since been fixed in the development
codebranch.

Note You need to log in before you can comment on or make changes to this bug.