Bug 910559 - radeon driver cannot handle restarting xorg server sometimes (fails with: *ERROR* Failed to parse relocation -35!)
radeon driver cannot handle restarting xorg server sometimes (fails with: *ER...
Status: CLOSED DUPLICATE of bug 849347
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
RejectedNTH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-12 15:52 EST by Hin-Tak Leung
Modified: 2013-02-14 10:36 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 849347
Environment:
Last Closed: 2013-02-14 10:36:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (38.08 KB, text/plain)
2013-02-13 12:01 EST, Hin-Tak Leung
no flags Details
dmesg soon after boot (67.28 KB, application/octet-stream)
2013-02-13 12:02 EST, Hin-Tak Leung
no flags Details

  None (edit)
Description Hin-Tak Leung 2013-02-12 15:52:05 EST
Bug 849347 comment 36 says "one person one bug rule", so here it is.

Hardware: toshiba laptop, single LCD, no external monitor.

about every 1.5 sec:
-------
Feb 10 14:36:59 localhost kernel: [ 1316.385962] [drm] radeon: ring at 0x0000000080001000
Feb 10 14:36:59 localhost kernel: [ 1316.385990] [drm] ring test succeeded in 0 usecs
Feb 10 14:36:59 localhost kernel: [ 1316.387118] [drm] ib test succeeded in 0 usecs
Feb 10 14:36:59 localhost kernel: [ 1316.794125] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation -35!
Feb 10 14:36:59 localhost kernel: [ 1316.795661] radeon 0000:01:05.0: GPU reset succeeded, trying to resume
Feb 10 14:37:00 localhost kernel: [ 1317.609150] [drm] radeon: 1 quad pipes, 1 z pipes initialized.
Feb 10 14:37:00 localhost kernel: [ 1317.629865] [drm] PCIE GART of 512M enabled (table at 0x0000000035C00000).
Feb 10 14:37:00 localhost kernel: [ 1317.629902] radeon 0000:01:05.0: WB enabled
Feb 10 14:37:00 localhost kernel: [ 1317.629912] radeon 0000:01:05.0: fence driver on ring 0 use gpu addr 0x0000000080000000 and cpu addr 0xffff880036387000
------------

-------------
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS690M [Radeon X1200 Series] (prog-if 00 [VGA controller])
	Subsystem: Toshiba America Info Systems Device ff1a
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64, Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 43
	Region 0: Memory at f0000000 (64-bit, prefetchable) [size=128M]
	Region 2: Memory at f8100000 (64-bit, non-prefetchable) [size=64K]
	Region 4: I/O ports at 9000 [size=256]
	Region 5: Memory at f8000000 (32-bit, non-prefetchable) [size=1M]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [50] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit+
		Address: 00000000fee0300c  Data: 41e1
	Kernel driver in use: radeon
----------------
Most of my details are in:
https://bugzilla.redhat.com/show_bug.cgi?id=849347#c14
and needless to say, the new mesa packages in comment 30 did not improve.

I'll attach dmesg and Xorg soon.

+++ This bug was initially created as a clone of Bug #849347 +++
Comment 1 Hin-Tak Leung 2013-02-12 15:57:33 EST
I am fairly sure it is not the kernel, since I was running up-to-date F17 happily until Dec 22 when I put f18 rc3 (rc4?) on, and essentially same kernel 3.7.x across. So it is probably libdrm, Xorg, ati, or mesa.
Comment 2 Matt Hirsch 2013-02-13 11:36:45 EST
I'll just note that I have the same symptoms with the same history: it worked on a fully updated f17, and broke when I switched to f18.

Compaq laptop. Single monitor.

01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4200 Series] (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Device 1604
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 18
	Region 0: Memory at e0000000 (32-bit, prefetchable) [size=256M]
	Region 1: I/O ports at 3000 [size=256]
	Region 2: Memory at f0300000 (32-bit, non-prefetchable) [size=64K]
	Region 5: Memory at f0200000 (32-bit, non-prefetchable) [size=1M]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: radeon
Comment 3 Hin-Tak Leung 2013-02-13 12:01:21 EST
Created attachment 696914 [details]
Xorg.0.log

Xorg.0.log soon after boot up - before any problems.
Comment 4 Hin-Tak Leung 2013-02-13 12:02:07 EST
Created attachment 696915 [details]
dmesg soon after boot

dmesg soon after boot
Comment 5 Hin-Tak Leung 2013-02-13 12:06:05 EST
(In reply to comment #2)
> I'll just note that I have the same symptoms with the same history: it
> worked on a fully updated f17, and broke when I switched to f18.
> 
> Compaq laptop. Single monitor.

Do you mean the laptop's built-in LCD (like I have), or one *external* monitor?
 
> 01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI
> RS880M [Mobility Radeon HD 4200 Series] (prog-if 00 [VGA controller])
...
> 	Capabilities: <access denied>
...

you may want to run lspci as root to get more info, if that matters. Normal user cannot see some of the device's properties.
Comment 6 Matt Hirsch 2013-02-13 20:21:03 EST
I mean the laptop's built-in screen.
Comment 7 Jérôme Glisse 2013-02-14 10:36:25 EST

*** This bug has been marked as a duplicate of bug 849347 ***

Note You need to log in before you can comment on or make changes to this bug.