This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 91062 - error changing display manager
error changing display manager
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-16 18:28 EDT by Paolo Holzl
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:34:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Holzl 2003-05-16 18:28:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Reading /etc/X11/prefdm
$DISPLAYMANAGER is used to change selected
display manager using data from file
/etc/systemconfig/desktop
Writing at this file not GNOME (KDE for example)
DISPLAYMANAGER=KDE
At startup and shoutdown all work correct.
The problem is changing user exiting from KDE or GNOME, the screen is black and
the system dont' work

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.edit file /etc/sysconfig/desktop
2.insert line DISPLAYMANAGER=KDE
3.if display manager start at startup reboot
4.logon as user or root at gnome or kde
5.select exit to reenter as another user
    

Actual Results:  The screen is black and the system is bolocked

Expected Results:  return to logon manager

Additional info:

probing ctrl-alt F1 or ctrl-alt backspace or ctrl-alt - or ctrl-alt + i don't
obtain result
Comment 1 John Horne 2003-05-20 12:03:48 EDT
Possibly relevant:
doing testing this morning and changed system to use xdm (DISPLAYMANAGER=XDM).
Upon reboot got error message 'xrdb: unknown command' - or some such message.
(Sorry the actual log file has been overwritten now.)
Got around this by changing /etc/X11/xdm/Xsetup_0 to specify '/usr/bin/X11/xrdb'
rather than just 'xrdb' (in line 9). However it could have just been me doing
something wrong!
Comment 2 Mike A. Harris 2003-05-26 00:26:46 EDT
Changing component to kdebase, as kdm isn't a part of XFree86.
Comment 3 Ngo Than 2003-05-26 15:51:49 EDT
Does it work if you change DISPLAYMANAGER to XDM or GNOME?

It's strange, i cannot reproduce this problem!

Could you please attach all config files under /etc/X11/xdm/ ?

which XFree86 version is running on your machine?
Comment 4 Bill Nottingham 2006-10-18 14:34:17 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.