Bug 910633 - openvswitch package for EPEL (el6)
openvswitch package for EPEL (el6)
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: openstack-quantum (Show other bugs)
el6
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bob Kukura
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-12 22:40 EST by Allan Feid
Modified: 2014-02-27 18:17 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-26 13:55:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
openvswitch-1.7.3-el6.patch (692 bytes, text/plain)
2013-02-12 22:40 EST, Allan Feid
no flags Details
openvswitch.spec (4.84 KB, text/plain)
2013-02-12 22:43 EST, Allan Feid
no flags Details

  None (edit)
Description Allan Feid 2013-02-12 22:40:03 EST
Created attachment 696698 [details]
openvswitch-1.7.3-el6.patch

Hello, I'm posting this to get some insight as to whether an EL6 package for openvswitch is planning on being released in EPEL. I've successfully been able to package this myself as it simply requires a  basic patch to the source and a slight modification to the spec file provided by the Open vSwitch project. I've attached the patch and will attach the spec file. The reason I'm asking is because it is kind of necessary for the OpenStack Quantum service. The bridge driver works well, but openvswitch provides much more flexibility.
Comment 1 Allan Feid 2013-02-12 22:43:55 EST
Created attachment 696699 [details]
openvswitch.spec

all I did to the upstream provided spec file was add openssl as a requirement, add openssl-devel as a build requirement and add the supplied patch
Comment 2 Pádraig Brady 2013-05-26 13:55:09 EDT
Note openstack on RHEL (derivatives) is now being provided through RDO at http://openstack.redhat.com/

openvswitch is available at the repository linked there.

Note I would advise waiting a few days before using the quantum from RDO as there are pending changes in the pipeline to fix various issues. I.E. wait until you see quantum updated from the openstack-quantum-2013.1-3 version there.

Note You need to log in before you can comment on or make changes to this bug.