Bug 91068 - exception.py:280:handleException:TypeError:generic_error_dialog() got an unexpected keyword argument 'dialog_type'
exception.py:280:handleException:TypeError:generic_error_dialog() got an unex...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-17 05:28 EDT by Magnus Dahl
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 10:10:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Magnus Dahl 2003-05-17 05:28:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
This is on a laptop Dell C600. When installing it was attached to the docking
station which includes a nic. The laptop in itself includes a nic and a wireless
nic on a mini PCI-card. The installation went fine. Everything seemed to work.
Then I detached the laptop from the docking station and rebooted.

The booter tells me that a nic (the docking station) is missing and I choose to
keep the config.

Now when I try to open the redhat-config-network it dumps because the wrong
driver is pointed.

Version-Release number of selected component (if applicable):
1.2.0

How reproducible:
Didn't try

Steps to Reproduce:
1. See above description
2.
3.
    

Actual Results:  The config tool dumps.

Expected Results:  I would like to be able to use the redaht-network-config tool.

Additional info:

Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/lib/python2.2/site-packages/rhpl/exception.py:280:handleException:TypeError:
generic_error_dialog() got an unexpected keyword argument 'dialog_type'
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 169, in ?
    handleException(sys.exc_info(), PROGNAME, PRG_VERSION)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 280, in
handleException
    dialog_type = "info")
TypeError: generic_error_dialog() got an unexpected keyword argument 'dialog_type'
Comment 1 Harald Hoyer 2003-05-19 07:34:57 EDT
Please try the update on
http://people.redhat.com/harald/redhat-config-network
Comment 2 Harald Hoyer 2003-08-11 10:10:33 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html

Note You need to log in before you can comment on or make changes to this bug.