Bug 910699 - Review Request: pagekite - makes localhost servers visible to the world
Summary: Review Request: pagekite - makes localhost servers visible to the world
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 910146
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-13 10:27 UTC by Lukas Zapletal
Modified: 2018-03-20 17:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-20 17:04:15 UTC
msuchy: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Lukas Zapletal 2013-02-13 10:27:01 UTC
Spec URL: https://raw.github.com/lzap/spec_reviews/master/pagekite.spec
SRPM URL: http://lzap.fedorapeople.org/fedora-packaging/pagekite/0.5.5a/pagekite-0.5.5a-1.src.rpm
RPM URL: http://lzap.fedorapeople.org/fedora-packaging/pagekite/0.5.5a/pagekite-0.5.5a-1.noarch.rpm
Description: 

PageKite is a system for running publicly visible servers (generally
web servers) on machines without a direct connection to the Internet,
such as mobile devices or computers behind restrictive firewalls.
PageKite works around NAT, firewalls and IP-address limitations by
using a combination of  tunnels and reverse proxies.

Natively supported protocols: HTTP, HTTPS
Partially supported protocols: IRC, Finger

Any other TCP-based service, including SSH and VNC, may be exposed
as well to clients supporting HTTP Proxies.

More info at: 

Fedora Account System Username: lzap

Notes:

Several rpmlint warnings and errors:

pagekite.noarch: W: invalid-license AGPLv3+

This is valid license now.

pagekite.noarch: E: non-executable-script /usr/lib/python2.7/site-packages/pagekite/proto/selectables.py 0644L /usr/bin/python

All the python files do have python shebang, because the upstream also distributes as an embedded app (in one file). If this is an issue for Fedora, I will have to remove this in the %build section.

pagekite.noarch: W: manual-page-warning /usr/share/man/man1/lapcat.1.gz 53: warning: macro `..' not defined

Fixed upstream already. Pending review.

pagekite.noarch: E: non-readable /etc/pagekite.d/10_account.rc 0660L

All the configuration files in this directory can contain sensitive information (api key), thus 660 root/root.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4955626

Comment 1 Lukas Zapletal 2013-02-13 10:28:43 UTC
More info at: https://pagekite.net/

Comment 2 Miroslav Suchý 2013-02-19 11:38:20 UTC
> All the python files do have python shebang, because the upstream also
> distributes as an embedded app (in one file). If this is an issue for Fedora,
> I will have to remove this in the %build section.

Please do so. Or add executable flag to those files. Whatever you feel as appropriate.

[!]: Package contains BR: python2-devel or python3-devel
See: http://fedoraproject.org/wiki/Packaging:Python#BuildRequires

This package requires python-SocksipyChain but I do not see such package in Fedora. Aha bug 910146.

Comment 3 Lukas Zapletal 2013-02-20 20:26:48 UTC
Fixed!

Spec URL: https://raw.github.com/lzap/spec_reviews/master/pagekite.spec
SRPM URL: http://lzap.fedorapeople.org/fedora-packaging/pagekite/0.5.5a-2/pagekite-0.5.5a-2.src.rpm
RPM URL: http://lzap.fedorapeople.org/fedora-packaging/pagekite/0.5.5a-2/pagekite-0.5.5a-2.noarch.rpm

$ rpmlint pagekite-0.5.5a-1.noarch.rpm 
pagekite.noarch: W: spelling-error Summary(en_US) localhost -> local host, local-host, holocaust
pagekite.noarch: W: name-repeated-in-summary C PageKite
pagekite.noarch: W: spelling-error %description -l en_US Natively -> Naively, Negatively, Tentatively
pagekite.noarch: W: incoherent-version-in-changelog 0.5.5a-2 ['0.5.5a-1', '0.5.5a-1']
pagekite.noarch: W: invalid-license AGPLv3+
pagekite.noarch: E: non-readable /etc/pagekite.d/80_httpd.rc.sample 0660L
pagekite.noarch: W: non-conffile-in-etc /etc/logrotate.d/pagekite
pagekite.noarch: E: non-readable /etc/pagekite.d/20_frontends.rc 0660L
pagekite.noarch: E: non-readable /etc/pagekite.d/10_account.rc 0660L
pagekite.noarch: E: non-readable /etc/pagekite.d/80_sshd.rc.sample 0660L
1 packages and 0 specfiles checked; 4 errors, 6 warnings.

Comment 4 Miroslav Suchý 2013-03-15 09:33:10 UTC
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
     Note: %defattr present but not needed
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package complies to the Packaging Guidelines
[x]: License field in the package spec file matches the actual license.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[x]: Package contains systemd file(s) if in need.
[-]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 51200 bytes in 3 files.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: %config files are marked noreplace or the reason is justified.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: No %config files under /usr.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).

Python:
[x]: Python eggs must not download any dependencies during the build process.
[-]: A package which is used by another package via an egg interface should
     provide egg info.
[x]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[!]: Dist tag is present.
[x]: Buildroot is not present
     Note: Buildroot: present but not needed
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
     Note: %clean present but not required
[x]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Issues:
* Please use dist tag in Release (this is only one blocker)
* scriplets for services can be written little bit better. See:
http://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
* Do not repeat package name in Summary. It should be:
Summary:    Makes localhost servers visible to the world

And I would remove those:
%if 0%{?rhel} && 0%{?rhel} <= 5
Who cares about RHEL4? And your spec is not ready for RHEL, neither 4 nor 5 or 6, because of systemd requirement.

Comment 6 Miroslav Suchý 2013-03-19 16:48:27 UTC
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
     Note: %defattr present but not needed
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package complies to the Packaging Guidelines
[!]: License field in the package spec file matches the actual license.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[x]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[x]: Package contains systemd file(s) if in need.
[-]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 51200 bytes in 3 files.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: %config files are marked noreplace or the reason is justified.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: No %config files under /usr.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).

Python:
[-]: Python eggs must not download any dependencies during the build process.
[-]: A package which is used by another package via an egg interface should
     provide egg info.
[x]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[x]: Buildroot is not present
     Note: Buildroot: present but not needed
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
     Note: %clean present but not required
[x]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).

Issue:
From project page:
Configuration files and examples are placed in the Public Domain.
So License IMO should be:
# Config files are Public Domain everything else is AGPLv3+
License:    AGPLv3+ and Public Domain

Comment 7 Lukas Zapletal 2013-03-30 19:37:30 UTC
https://github.com/lzap/spec_reviews/commit/2be6b8a5f9293503ca7cb0a04c19901471cb816e

License fixed, good point. I am not going to make another build for this one if you do not mind.

Comment 8 Miroslav Suchý 2013-04-03 14:03:13 UTC
It is better to include that comment which explain why two licenses:

# Config files are Public Domain everything else is AGPLv3+

But OK. That was last item.

APPROVED.

Comment 9 Lukas Zapletal 2013-04-04 10:31:23 UTC
New Package SCM Request
=======================
Package Name: pagekite
Short Description: system for running publicly visible servers
Owners: lzap
Branches: f18 f19 el5 el6

(If there is f19 branch already - not sure :-)

Thank you Mirek!

Comment 10 Gwyn Ciesla 2013-04-04 12:42:44 UTC
Git done (by process-git-requests).

Comment 12 Lukas Zapletal 2013-11-11 09:30:48 UTC
Finally, pagekite was pushed to testing.

Comment 13 Fedora Update System 2018-03-02 09:42:57 UTC
pagekite-0.5.9.2-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-a7578c5325

Comment 14 Fedora Update System 2018-03-02 18:36:08 UTC
pagekite-0.5.9.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-a7578c5325

Comment 15 Fedora Update System 2018-03-20 17:04:15 UTC
pagekite-0.5.9.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.