Bug 9107 - 6.1 fails to find Addonics (NEC) CDROM dive to install
Summary: 6.1 fails to find Addonics (NEC) CDROM dive to install
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-04 00:52 UTC by trandall
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-12 18:14:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description trandall 2000-02-04 00:52:26 UTC
Trying to install Red Hat 6.1 on IBM Thinkpad 755CE using Addonics (NEC)
PCMCIA CDROM drive.  Tried the Red Hat 6.1 PCMCIA boot disk.  CDROM seems
to be found (lights up and spins up), but then gets lost, and the install
program demands a driver disk.  Red Hat has none.  5.2 installs OK, but it
has a supplemental driver disk.  Addonics doesn't have a driver on their
web site for 6.1 (yet, I hope).  I've asked them about this but no reply
yet.  During the install: Checking ALT+F3 shows many reports (some end in
(path is NULL), interesting ones - cardmgr returned 0x0; failed to open 3
files (/tmp/drivers/modules.cgz, /tmp/drivers/modinfo, /tmp/drivers
/modules.dep). All 3 show "No such file or directory."
Checking ALT+F4 shows: finds CDROM, lists much info (at this point CDROM
lights up and spins the disk), then reports: fopen(stabfile) failed: No
such file or directory. So the install program finds the CDROM then loses
it. I've tried boot disks with images from the Red Hat CDROM and from the
Errata page on the web site.  I've tried both the boot and pcmcia disk
versions from both.  I've tried graphic, text and expert installs.  They
all want a driver disk!!  5.2 had one - 6.1 doesn't.  5.2 installs - 6.1
doesn't.  RedHat says driver disk mechanism was changed to make it easier
for third party vendors to have driver disks. It's not easier for me!  Re
Hat tech support referred me to Buzilla, so, give it a shot!  Thanks.

Comment 1 Jay Turner 2000-02-04 18:22:59 UTC
Not quite sure why you are even getting the driver disk screen unless you are
running in expert mode, or the installer is not finding any autoprobed equipment
on your machine.  Anyway, the fact that the installer is prompting for a boot
disk may mean nothing.  It certainly does not mean that it wants a disk for your
CDROM drive.

Basically, we should have put better text on the driver disk screen.  It is for
use if you have a driver disk in hand.  So, basically this is the point where
the installer is saying, "If you have a driver disk, please insert it now,
otherwise click cancel and we will continue."  The installer is not trying to
tell you that it has to have one, just that if you have one you are to use it
there.

The text that you are seeing on the VCs is actually pretty normal.  The stuff
ending with "(path is NULL)" is actually normal, as is the stuff about not being
able to find files in the /tmp/drivers directory (these are files that would
normally be on a driver disk . . . since you do not have one, it failed to find
those files!)

Try running the install again, and if you get the Driver Disk screen, just hit
"Cancel" and continue on.  Submit to me details of what happens from there.  I
think that this will actually work for you without any further tasks on your
part.  If you do have trouble, just post it here and we will take a look at it.

Comment 2 Michael Fulbright 2000-06-12 18:14:13 UTC
Closed due to inactivity.


Note You need to log in before you can comment on or make changes to this bug.