Bug 91071 - Filename completion doesn't work properly in shell if previously a change of directory using wildcards has taken place
Filename completion doesn't work properly in shell if previously a change of...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-17 06:50 EDT by Kyriakos Sidiropoulos
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 01:57:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyriakos Sidiropoulos 2003-05-17 06:50:56 EDT
Description of problem:
Filename completion doesn't work properly  at  Eshell
if  previously  a change of directory using wildcards
 has taken place.


Version-Release number of selected component (if applicable):
GNU Emacs 21.2.1


How reproducible:
Always reproducable (in the following way)

Steps to Reproduce:
1) F3
2) mkdir -p foo1/foo2; touch foo1/first foo1/foo2/second; cd foo1
3) cd *o2
4) Type: 'ls se' and press Tab.

    
Actual results:
An error beep is heard and nothing happens.


Expected results:
The filename 'second' should have been auto-completed.


Additional info:
After step 3 do:

4) C-d
5) F3

The new Eshell places us to the 'foo1' directory instead
of the 'foo2' directory. This looks suspicious.
Comment 1 Jens Petersen 2003-05-20 03:56:03 EDT
I don't understand what "F3" is supposed to do for you.
Is it some local key binding you have?

Anyway I am unable to reproduce the rest of the report with emacs 21.3,
except for the additional steps you mention which I don't understand either.
So perhaps you might like to upgrade to the emacs in rawhide and test with that.

Comment 2 Kyriakos Sidiropoulos 2003-05-20 06:50:54 EDT
Ough! Sorry! You are right. Two mistakes I've done: I meant to say Shell - not
Eshell. And F3 is my shortcut for 'M-x shell' for opening this (mere) shell. C-d
(CTRL-d), at the additional steps, kills the shell previously opened and F3
(which is: 'M-x shell') opens a new one. This new shell starts in a different
directory than the one the previous shell was at when it was killed (normally
this shouldn't be the case). I just mentioned it in case it could give a clue.
Sorry for the drag.
Comment 3 Jens Petersen 2003-05-22 08:23:24 EDT
Ah, shell-mode - yep I'm not surprised.

Ok, please report the problem upstream to the Emacs developers -
eg to <bug-gnu-emacs@gnu.org>.
Thank you.
Comment 4 Jens Petersen 2004-01-15 00:32:32 EST
This still occurs in current cvs emacs.

Note You need to log in before you can comment on or make changes to this bug.