Bug 91103 - ppp-watch fails, cannot update hcfpcimodem, trouble with i18n
ppp-watch fails, cannot update hcfpcimodem, trouble with i18n
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-18 10:57 EDT by Cyrille Bollu
Modified: 2014-03-16 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-03 20:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cyrille Bollu 2003-05-18 10:57:37 EDT
Description of problem:
Hi,

from today on, /sbin/ifup cannot connect my computer to the internet anymore. I 
have a conexant HCF modem and I'm using initscripts-7.14-1.
Usually when I have this kind of problem I re-install the hcfpcimodem drivers 
but now I even cannot re-install them anymore (That's why I think it has 
something to do with i18n. see later). Now, I have to use W98/IE5.0 to be able 
to connect to the internet.

The story begans like this:
I issued the command "/sbin/ifup ppp0", but it echo "Failed to activate ppp0 
with error 7". After investigation, I could find that this message is thrown 
from ppp-watch.

As usual when I have this kind of problem with my modem, I tried to re-install 
the hcfpcimodem drivers but this time it simply hangs while executing a gawk 
command.

Why I think it's related to i18n?  It's because I updated the 
file /etc/sysconfig/i18n last days trying to solve some problems with french 
characters at boot-time... And because of the gawk problem above.

At last, I restored the original i18n file but it did'nt do the trick.

Could you help me?

PS: By the way, I succeded with the french characters at boot-time problem by 
using locales fr_FR.utf8 and font lat9w (something like that). But I still got 
a problem with a directory called "Stéphanie" on my shared FAT32 partition. 
Could you do something for that also?

Waiting to read from you,

Cyrille

Version-Release number of selected component (if applicable):
7.14-1

How reproducible:
Always

Steps to Reproduce:
(here's what I did to encounter the problem as I remember)
1. update your i18n files with locale "fr_FR.utf8" and font lat9w.
2. restart your computer/shutdon your computer/restart your computer.
3. change some settings in your modem settings.
4. restart your computer.
5. /sbin/ifup ppp0
    
Actual results:
"Failed to activate ppp0 with error 7"

Expected results:
connect to the internet.

Additional info:
Comment 1 Bill Nottingham 2003-05-18 21:21:27 EDT
Does it behave any better if you use 'fr_FR.UTF-8'? It shouldn't, but...

Error 7 does mean that it can't open the serial port, which usually does
indicate a driver problem.
Comment 2 Bill Nottingham 2003-09-03 20:14:27 EDT
You might try reinstalling the hcimodem drivers with no locale set, run:

export LANG=C

before installing.

Aside from that, the 'Error 7' does imply a driver problem; that really can't be
solved in initscripts.

Note You need to log in before you can comment on or make changes to this bug.