Bug 91104 - libmilter but no milter support in sendmail
Summary: libmilter but no milter support in sendmail
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-18 15:26 UTC by Kenneth Porter
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-11 14:57:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kenneth Porter 2003-05-18 15:26:49 UTC
libmilter is built, but the sendmail binary lacks milter support in 8.12.9-6.
Need the following in redhat.config.m4:

APPENDDEF(`conf_sendmail_ENVDEF', `-DMILTER')
APPENDDEF(`conf_libmilter_ENVDEF', `-D_FFR_MILTER_ROOT_UNSAFE')

Comment 1 Kenneth Porter 2003-05-19 23:31:14 UTC
After learning that the same RPM built on RH9 provides MILTER fine, I looked
more closely at what was going on, and see that redhat.config.m4 is built using
one of 3 different patches, based on OS version. For some reason MILTER is not
included when building on 7.2 or earlier. Why not?

It would seem that either it should be included or libmilter should not be built
if milter support is not wanted, since a milter built without a milter-capable
sendmail is useless.

Comment 2 Florian La Roche 2003-12-11 14:57:43 UTC
The current rpm does not support building on older releases without
some changes in it. If you send in patches that improve the current
situation, I can look at merging them in. I don't plan on doing this
from my end.

greetings,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.