Bug 91109 - Terminating "top" usually leaves console in bold font
Terminating "top" usually leaves console in bold font
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
7.3
All Linux
medium Severity low
: ---
: ---
Assigned To: Alexander Larsson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-18 17:07 EDT by Robert La Ferla
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-19 05:29:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert La Ferla 2003-05-18 17:07:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030517

Description of problem:
If you run "top" and then use "Ctrl-c" to terminate the process, the
terminal/console will sometimes be left in bold font.  The bug is always present
but because it is "timing" related in that it depends on when the Ctrl-c signal
is sent vs. what portion of the display the "top" command is refreshing.

Recommended fix: Need to catch the SIGINT signal and send a bold-off sequence to
the terminal.


Version-Release number of selected component (if applicable):
procps-2.0.7-11

How reproducible:
Always

Steps to Reproduce:
1.  Run "top" command from a terminal (vt100, vt220, etc...)
2.  Press "Ctrl-c" to terminate the program.
3.  If your prompt did not change to bold, keep repeating steps 1+2.
    

Actual Results:  The console is left in BOLD font.

Expected Results:  The console should be in whatever the font was before you
executed the program.

Additional info:
Comment 1 Alexander Larsson 2003-05-19 05:29:17 EDT
This is true of all applications that use text attributes, but making everything
catch SIGINT (and all other signals that can terminate the process) is not the
answer.
The supported way to exit top is to press 'q'. If you do this the console will
never be bold. If you ever get the console into a bold (or other attribute)
state,  the "reset" command fixes this for you.

Note You need to log in before you can comment on or make changes to this bug.