Bug 9111 - Can't overlay different versions of the same package
Summary: Can't overlay different versions of the same package
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-04 07:49 UTC by Stephen Rasku
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-07 21:52:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Rasku 2000-02-04 07:49:48 UTC
I was trying to install XFree86 3.3.6.  This requires a new module called
kudzu and this requires a new version of newt.  However, there are a bunch
of existing packages that depend on the old version of newt (BTW, shouldn't
they be backward compatible so that I can use a newer version of the
libraries with older applications?).  So I can't install the newer version
of newt because of the old packages and I can't install kudzu because it
requires the newest version newt.  It would be good to be able to have
libnewt.so.0.50 and libnewt.so.0.40 installed at the same time so that
everything works.

[root@granite X]# rpm -ih kudzu-0.26-1.i386.rpm
error: failed dependencies:
        libnewt.so.0.50 is needed by kudzu-0.26-1
[root@granite X]# rpm -q newt
newt-0.40-9
[root@granite X]# rpm -Fh newt-0.50.6-1.i386.rpm
error: failed dependencies:
        libnewt.so.0.40 is needed by authconfig-1.8-1
        libnewt.so.0.40 is needed by kbdconfig-1.9.2-1
        libnewt.so.0.40 is needed by mouseconfig-3.9-1
        libnewt.so.0.40 is needed by ntsysv-1.0.6-1
        libnewt.so.0.40 is needed by rhs-hwdiag-0.36-1
        libnewt.so.0.40 is needed by setuptool-1.2-2
        libnewt.so.0.40 is needed by sndconfig-0.33-1
        libnewt.so.0.40 is needed by timeconfig-2.7-1
        libnewt.so.0.40 is needed by Xconfigurator-4.2.3-1

Comment 1 Jeff Johnson 2000-02-07 21:52:59 UTC
You need to upgrade all that packages that require newt as well as XFree
and kudzu.


Note You need to log in before you can comment on or make changes to this bug.