Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 911178

Summary: warnings at startup of VDSM (related to MOM, rest server and json rpc server)
Product: Red Hat Enterprise Virtualization Manager Reporter: Yaniv Kaul <ykaul>
Component: vdsmAssignee: Yaniv Bronhaim <ybronhei>
Status: CLOSED CURRENTRELEASE QA Contact: Ido Begun <ibegun>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.1.3CC: abaron, bazulay, danken, dfediuck, dyasny, hateya, iheim, jkt, knesenko, lpeer, oramraz, sgrinber, ykaul
Target Milestone: ---Keywords: Regression
Target Release: 3.2.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: vdsm-4.10.2-10.0.el6ev Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 917401    

Description Yaniv Kaul 2013-02-14 14:33:06 UTC
Description of problem:
In /var/log/messages, when start VDSM:
Feb 14 16:25:48 puma39 vdsm vds WARNING MOM initialization failed and fall back to KsmMonitor#012Traceback (most recent call last):#012  File "/usr/share/vdsm/clientIF.py", line 194, in _prepareMOM#012    self.mom = MomThread(momconf)#012  File "/usr/share/vdsm/momIF.py", line 34, in __init__#012    raise Exception("MOM is not available")#012Exception: MOM is not available
Feb 14 16:25:48 puma39 vdsm vds WARNING Unable to load the rest server module. Please make sure it is installed.
Feb 14 16:25:48 puma39 vdsm vds WARNING Unable to load the json rpc server module. Please make sure it is installed.


Version-Release number of selected component (if applicable):
vdsm-4.10.2-1.4.el6.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 Doron Fediuck 2013-02-15 15:37:59 UTC
MOM integration is just warning that it's falling back to the previous ksm integration. This warning is not an issue. REST and json could be more meaningful.

Comment 5 Yaniv Bronhaim 2013-02-18 12:44:59 UTC
The warnings are meaningful. It means that in your config.py file the variables xmlrpc_enable jsonrpc_enable are set to true and the rpms vdsm-xmlrpc and vdsm-jsonrpc are not installed. And if you planed to use it as you set it to enabled, you probably meant to install it.. 

I didn't understand what is wrong with that and what do you want to do with those warning? Omit them?

Comment 11 Yaniv Bronhaim 2013-02-19 15:58:06 UTC
You should install vdsm-xmlrpc and vdsm-jsonrpc to avoid this errors..
Do you suggest to set those parameters to disable as default?

Comment 12 Dan Kenigsberg 2013-02-24 13:29:20 UTC
we do not ship or support -jsonrpc and -rest downstream, so indeed we should not even try to load them. Best and simple is a two-liner change config.py: flip the defaults of jsonrpc_enable/rest_enable to false.

I prefer that, as I like DOWNSTREAM ONLY changes to be minimal.

Comment 13 Ido Begun 2013-03-21 06:58:22 UTC
OK - SF10.1

No warning about rest server or json rpc modules are given when VDSM starts up.

Comment 14 Itamar Heim 2013-06-11 09:06:14 UTC
3.2 has been released

Comment 15 Itamar Heim 2013-06-11 09:06:14 UTC
3.2 has been released

Comment 16 Itamar Heim 2013-06-11 09:06:18 UTC
3.2 has been released

Comment 17 Itamar Heim 2013-06-11 09:06:20 UTC
3.2 has been released

Comment 18 Itamar Heim 2013-06-11 09:34:56 UTC
3.2 has been released