Bug 911314 - FTBFS: SpiderMonkey compiled with incorrect page size; please update js/src/gc/Heap.h.
Summary: FTBFS: SpiderMonkey compiled with incorrect page size; please update js/src/g...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xulrunner
Version: 18
Hardware: ppc
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-14 17:30 UTC by Gustavo Luiz Duarte
Modified: 2013-06-01 02:27 UTC (History)
6 users (show)

Fixed In Version: xulrunner-21.0-4.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 17:38:10 UTC


Attachments (Terms of Use)
Use the runtime page size to control arena decommit (16.96 KB, patch)
2013-02-15 16:44 UTC, Gustavo Luiz Duarte
no flags Details | Diff
Use the runtime page size to control arena decommit (Firefox 19) (17.04 KB, patch)
2013-02-20 15:04 UTC, Gustavo Luiz Duarte
no flags Details | Diff

Description Gustavo Luiz Duarte 2013-02-14 17:30:15 UTC
Description of problem:
Xulrunner fails to build on 32 bits PPC whith the following error message:

SpiderMonkey compiled with incorrect page size; please update js/src/gc/Heap.h.
/bin/sh: line 1: 42595 Segmentation fault      (core dumped) /builddir/build/BUILD/xulrunner-18.0.2/mozilla-release/objdir/dist/bin/run-mozilla.sh /builddir/build/BUILD/xulrunner-18.0.2/mozilla-release/objdir/dist/bin/xpcshell -g "$PWD" -a "$PWD" -f /builddir/build/BUILD/xulrunner-18.0.2/mozilla-release/toolkit/mozapps/installer/precompile_cache.js -e "populate_startupcache('startupCache.zip');"


Version-Release number of selected component (if applicable):
xulrunner-18.0.2-1.fc18


How reproducible:
Always


Steps to Reproduce:
1. ppc-koji build --scratch f18 xulrunner-18.0.2-1.fc18.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=909712

Comment 1 Gustavo Luiz Duarte 2013-02-14 17:32:14 UTC
This is being tracked upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=840242

Comment 2 Gustavo Luiz Duarte 2013-02-15 16:44:08 UTC
Created attachment 697876 [details]
Use the runtime page size to control arena decommit

Terrence Cole's patch from upstream + return success when decommit is disabled + backport to Mozilla18.

This fixes the build issues and works fine on ppc64.

Comment 3 Martin Stransky 2013-02-20 12:52:35 UTC
Please update the patch for Firefox 19 and we'll put it to Fedora then.

Comment 4 Gustavo Luiz Duarte 2013-02-20 15:04:10 UTC
Created attachment 700086 [details]
Use the runtime page size to control arena decommit (Firefox 19)

Previous patch adapted to apply on Fedora 19.

I tested the attached patch and it builds fine both on ppc and ppc64. However Firefox 19 crashes on ppc64. This crash seems to be unrelated to the attached patch as Firefox 18 worked just fine. So please add this patch to Fedora. I will file a different bug for the Firefox 19 crashes.

Comment 5 Martin Stransky 2013-02-20 15:26:02 UTC
Okay, added to xulrunner.

Comment 6 Gustavo Luiz Duarte 2013-02-21 17:38:10 UTC
Fixed in xulrunner-19.0-2.fc19

Thanks Martin

Comment 7 Fedora Update System 2013-04-23 12:37:31 UTC
xulrunner-20.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xulrunner-20.0-4.fc18

Comment 8 Fedora Update System 2013-04-23 12:38:01 UTC
xulrunner-20.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xulrunner-20.0-4.fc17

Comment 9 Fedora Update System 2013-04-23 12:38:21 UTC
xulrunner-20.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xulrunner-20.0-4.fc19

Comment 10 Fedora Update System 2013-04-27 03:10:05 UTC
xulrunner-20.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-06-01 02:27:53 UTC
xulrunner-21.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.